Closed Bug 1663489 Opened 1 year ago Closed 1 year ago

print preview in nightly hangs on the return form from karaskustoms.com

Categories

(Core :: Print Preview, task, P1)

task

Tracking

()

RESOLVED DUPLICATE of bug 1663503

People

(Reporter: froydnj, Unassigned)

Details

(Whiteboard: [print2020_v81][old-ui-])

STR:

  1. Open https://karaskustoms.com/wp-content/uploads/2020/06/serviceform.pdf in Nightly
  2. Print.

ER:

A usable dialog.

AR:

A dialog that hangs at the "Preparing preview" step. It's not clear to me whether this is a problem rendering the document or whether there's some difficulty in contacting the printer. (My printer is a wake-on-demand printer, and I've never had any problems with it until recent Nightlies. about:buildconfig says that it's built from https://hg.mozilla.org/mozilla-central/rev/38df8f36910ce8bcc5609841908a52d9c3e6da37 ; a previous version from a week or so ago also displayed the hanging problem.)

Hi Nathan: Are you still able to print even though the preview never renders? And would you be willing to see if this replicates for you in the old print preview? (Disable print.tab_modal.enabled.)

Severity: -- → S3
Flags: needinfo?(nfroyd)
Priority: -- → P1
Whiteboard: [print2020_v81][old-ui?]

(In reply to Sean Voisen (:svoisen) from comment #1)

Hi Nathan: Are you still able to print even though the preview never renders? And would you be willing to see if this replicates for you in the old print preview? (Disable print.tab_modal.enabled.)

I am not able to print; the main (left-side) box just contains "Preparing Preview" and the spinner. The right-side sidebar with "Print" in bold at the top contains nothing. And since the dialog is tab-modal, I have to close the tab and reopen the document to do anything with it.

I am able to successfully print after setting print.tab_modal.enabled to false.

Flags: needinfo?(nfroyd)

NI Emilio so he's also aware, since he's been working on the PDF printing codepath.

Flags: needinfo?(emilio)
Whiteboard: [print2020_v81][old-ui?] → [print2020_v81][old-ui-]
Severity: S3 → S2

Hopefully this is a dup of bug 1663140.

Nathan can you please try the latest nightly?

Flags: needinfo?(nfroyd)

Yeah, I can't repro this off-hand but:

  • Does this happen with non-PDF documents?
  • Does this happen if you select other printer as a default that isn't an actual physical printer, like the "Save as PDF" printer? (If you can switch at all of course...)
Flags: needinfo?(emilio)

Latest Nightly (built from https://hg.mozilla.org/mozilla-central/rev/d4e11195e39888686d843a146a893eb0ebf38224) produces the same results as described in comment 0.

(In reply to Emilio Cobos Álvarez (:emilio) from comment #5)

Yeah, I can't repro this off-hand but:

  • Does this happen with non-PDF documents?

Yes, printing webpages does the same thing.

  • Does this happen if you select other printer as a default that isn't an actual physical printer, like the "Save as PDF" printer? (If you can switch at all of course...)

How would I do that? Do I have to disable the tab-modal dialog?

Flags: needinfo?(nfroyd)

Thank you Nathan!

(In reply to Nathan Froyd [:froydnj] from comment #6)

Latest Nightly (built from https://hg.mozilla.org/mozilla-central/rev/d4e11195e39888686d843a146a893eb0ebf38224) produces the same results as described in comment 0.

(In reply to Emilio Cobos Álvarez (:emilio) from comment #5)

Yeah, I can't repro this off-hand but:

  • Does this happen with non-PDF documents?

Yes, printing webpages does the same thing.

Then, it's a dup of bug 1663503?
Can you please check the browser toolbox whether there is any suspicious message.

I do get the same error messages that bug 1663503 comment 0 describes (though my "Can't fetchPaperMargins") stack is shorter), so it seems likely that this is a dup.

(In reply to Nathan Froyd [:froydnj] from comment #6)

How would I do that? Do I have to disable the tab-modal dialog?

D'oh, sorry, didn't notice you couldn't switch destination while the "preparing print preview" stuff was showing up. Setting the print_printer pref to Mozilla Save to PDF should get you the PDF printer selected, I think.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1663503
You need to log in before you can comment on or make changes to this bug.