Home and End keys reversed in inputs and textareas

VERIFIED FIXED

Status

()

P3
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: dbaron, Assigned: mjudge)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

DESCRIPTION:  The home and end keys are reversed in inputs (type=text) and
textareas.  Home goes to the end of a line and end goes to the beginning.  I
believe this is a recent regression, or possibly a bug in a new feature...


STEPS TO REPRODUCE:

 * Load this page
 * Type something into the textarea or the URL field
 * Hit home or end from somewhere in the middle of the line.

It does the reverse of what it should.

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-10-16-08-M11

Updated

19 years ago
Assignee: karnaze → buster

Comment 1

19 years ago
Reassigning to Steve.

Comment 2

19 years ago
Also DOES NOT WORK CORRECTLY ON:
Windows NT 4.0sp3, mozilla.exe, 1999-10-17-08-M11

Comment: there are many, many other text-entry oddities left in Mozilla
Form controls and the Location Bar.

Updated

19 years ago
Assignee: buster → mjudge

Comment 3

19 years ago
assigned to mike, cc kathy and frank in case it's a regression due to the key
event branch.

Comment 4

19 years ago
*** Bug 16941 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
This looks to be fixed. Marking verified. 1999110808, Linux.
You need to log in before you can comment on or make changes to this bug.