Closed Bug 1663898 Opened 6 months ago Closed 6 months ago

Has Cranelift really shipped on aarch64?

Categories

(Core :: Javascript: WebAssembly, defect)

defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox82 --- fixed

People

(Reporter: bbouvier, Assigned: bbouvier)

References

Details

Attachments

(1 file)

This is a bit embarrassing.

A current version of Fenix shows a build id which ought to contain Geckoview with the recent Cranelift changes, but about:config shows cranelift is disabled there.

Not sure, but it might be that the pref's default isn't enabled because the _ARM64_ define doesn't exist when substituting in modules/libpref/all/init.js.

Build peers: what should i use to test for a device running an aarch64 build, in modules/libpref/init/all.js? (Is _ARM64_ not substituted in this file?)

Flags: needinfo?(nfroyd)
Flags: needinfo?(mh+mozilla)

Nathan helped on matrix, thanks.

Flags: needinfo?(nfroyd)
Flags: needinfo?(mh+mozilla)
Assignee: nobody → bbouvier
Status: NEW → ASSIGNED

Confirmed the above patch is sufficient to enable Cranelift by default (at least according to the compiled Geckoview example from a try build with this patch).

Pushed by bbouvier@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/648847a283fe
Really enable Cranelift by default on aarch64 builds; r=froydnj
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
You need to log in before you can comment on or make changes to this bug.