Closed Bug 1663967 Opened 1 year ago Closed 11 months ago

Ship v16.0.0 of webcompat system addon

Categories

(Web Compatibility :: Interventions, task, P2)

Tracking

(firefox83 fixed)

RESOLVED FIXED
Tracking Status
firefox83 --- fixed

People

(Reporter: miketaylr, Assigned: denschub)

References

Details

Attachments

(2 files)

Soft freeze will be 2020-10-15, so let's try to land this around 2020-10-08.

Assignee: nobody → dschubert
Status: NEW → ASSIGNED
Depends on: 1668463
Depends on: 1668465
No longer blocks: 1316668
Depends on: 1316668
Pushed by dschubert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d4b7aea9a014
Ship v16.0.0 of webcompat system addon. r=ksenia,webcompat-reviewers

I don't know why that test fails. And after talking to Nika and Johann, it seems like this is a failure in the test, but a fairly complicated one. Disabling the test until it's fixed is not a great idea, especially since the code causing the issue is our new console notification, not an actual intervention.

I've filed bug 1670230 for investigating the test breakage. To get the new interventions shipped, I'll build v16.0.0 without the console notification and land that. We can land the console notification as a follow-up in v16.1.0 when the test is fixed, or we know how to work around that.

Flags: needinfo?(dschubert)
See Also: → 1670230
Pushed by dschubert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/714bfefe553a
Ship v16.0.0 of webcompat system addon. r=ksenia,webcompat-reviewers

Bug 1670241 will track re-landing the console notification code.

See Also: → 1670241
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Regressions: 1711940
You need to log in before you can comment on or make changes to this bug.