composer crashes when attempting to copy-paste text

VERIFIED DUPLICATE of bug 166056

Status

SeaMonkey
Composer
--
critical
VERIFIED DUPLICATE of bug 166056
16 years ago
14 years ago

People

(Reporter: Madhur Bhatia, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
platform : win 2000
build id : 2002-09-03-08trunk

I was attemting to copy and paste text within the composer when the crash occured.
Incident ID # 10316392
Stack Signature L MSVCRT.DLL + 0x11b09 (0x78011b09) 6897220f
(Reporter)

Updated

16 years ago
Severity: normal → critical
Keywords: crash

Comment 1

16 years ago
99% sure this is dupe of bug 166056.

Comment 2

16 years ago
Yes, this is a dupe of 166056.

MSVCRT.DLL + 0x11b09 (0x78011b09)
nsDataObj::GetText
[c:/builds/seamonkey/mozilla/widget/src/windows/nsDataObj.cpp, line 705]
nsDataObj::GetData
[c:/builds/seamonkey/mozilla/widget/src/windows/nsDataObj.cpp, line 247]
ole32.dll + 0x2940f (0x77a7940f)
FillSTGMedium [c:/builds/seamonkey/mozilla/widget/src/windows/nsClipboard.cpp,
line 366]
nsClipboard::GetNativeDataOffClipboard
[c:/builds/seamonkey/mozilla/widget/src/windows/nsClipboard.cpp, line 394]
nsClipboard::GetDataFromDataObject
[c:/builds/seamonkey/mozilla/widget/src/windows/nsClipboard.cpp, line 577]
nsClipboard::GetNativeClipboardData
[c:/builds/seamonkey/mozilla/widget/src/windows/nsClipboard.cpp, line 826]
nsBaseClipboard::GetData
[c:/builds/seamonkey/mozilla/widget/src/xpwidgets/nsBaseClipboard.cpp, line 130]
nsHTMLEditor::Paste
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLDataTransfer.cpp, line
1363]
nsPasteCommand::DoCommand
[c:/builds/seamonkey/mozilla/editor/libeditor/base/nsEditorCommands.cpp, line 327]
nsControllerCommandManager::DoCommand
[c:/builds/seamonkey/mozilla/embedding/components/commandhandler/src/nsControllerCommandManager.cpp,
line 190]
nsEditorController::DoCommand
[c:/builds/seamonkey/mozilla/editor/libeditor/base/nsEditorController.cpp, line 209]
nsXBLPrototypeHandler::ExecuteHandler
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp, line 328]
nsXBLWindowHandler::WalkHandlersInternal
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLWindowHandler.cpp, line 312]
nsXBLWindowKeyHandler::WalkHandlers
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLWindowKeyHandler.cpp, line 183]
nsXBLWindowKeyHandler::KeyPress
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLWindowKeyHandler.cpp, line 199]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1615]
nsWindowRoot::HandleChromeEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsWindowRoot.cpp, line 182]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 786]
nsXULDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp, line 2628]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3497]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3489]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3489]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3489]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3489]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3489]
nsXULElement::HandleChromeEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 4688]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 786]
nsDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp, line 3547]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2084]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6107]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6030]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2046]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 301]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1903]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1038]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1055]
nsWindow::DispatchKeyEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 2886]
nsWindow::OnChar [c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp,
line 3066]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3712]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1304]
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x30e0 (0x77e130e0)
USER32.DLL + 0x5824 (0x77e15824)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1523]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1870]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1888]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08)

*** This bug has been marked as a duplicate of 166056 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED

Comment 4

16 years ago
reassign in case bugs are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.