Closed Bug 1664793 Opened 1 year ago Closed 1 year ago

Scale option is being skipped during keyboard navigation

Categories

(Toolkit :: Printing, defect)

Desktop
All
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: vlucaci, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [print2020_v82][oldui-])

Attachments

(1 file)

Attached image Scale is skipped.gif

Affected versions

  • 82.0a1 (2020-09-14)
  • 81.0b9

Affected platforms

  • Windows 10x64
  • macOS 10.15.6

Steps to reproduce

  1. Launch FF.
  2. Trigger the new print modal.
  3. Press Tab multiple times.

Expected result

  • All options are highlighted and selected with each TAB buttons press.

Actual result

  • Scale radio option is skipped.

Suggested Severity

  • Seeing as how there is a simple workaround(using the mouse) and the fact that not functionality is affected, I would S3 this issue.

Regression range

  • Went as far back as 2020-07-31 and the issue occurs with the same repro steps. This issue is not a regression.

Additional notes

  • This issue does not occur on Ubuntu platform.
Has Regression Range: --- → no

It's a frontend issue, I think.

Component: Printing: Setup → Printing
Product: Core → Toolkit

I think that's expected, since it's a group of radio buttons, so hitting <tab> shouldn't change the setting. (Similar stuff happens with the Portrait/Landscape buttons.) There's more info at https://stackoverflow.com/questions/14322564/can-you-tab-through-all-radio-buttons

(Having said that, if :Jamie or :MarcoZ think we should do something different, then we should re-open this bug.)

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.