Mail search does a complete boolean evaluation

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Rene Pronk, Assigned: Howard Chu)

Tracking

({perf})

Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build 2002083108 on win2000

Mail search seems to do a complete boolean evaluation on the search criteria:
If I search for a subject containing 'qqqq' it won't find anything and
needs approx. 0.5 seconds for this.
If I search for a subject containing 'qqqq' *and* the body containing
'blablabla' it finds again nothing but now needs approx 17.5 seconds for
this.
It should of course do this last search also in 0.5 seconds since after
checking the subject it wouldn't need to check the body anymore.
The order in which I specify the criteria doesn't matter.
Ideally Mozilla should reorder the criteria such that the fastest/easiest
criteria would be matched first and the slow ones last.

Comment 1

16 years ago

I've always assumed that if you're doing a 'match all criteria', it uses lazy 
evaluation on the criteria. fixing this would make the freezing/ 100% cpu usage 
issues of critical bug

http://bugzilla.mozilla.org/show_bug.cgi?id=127398

much less severe in practical terms. I often used a subject=/sender= filter in 
conjunction with body= in order to make it faster, but I now realise this is 
pointless.

The re-ordering is actually pretty simple; all apart from body= use the summary 
file (correct?), and are quick,  so it just has to put any body= searches last. 

This would be a huge perf win in many search cases.


mass re-assign.
Assignee: naving → sspitzer

Comment 3

14 years ago
*** Bug 245593 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking-aviary1.0?

Comment 4

14 years ago
not a 1.0 stopper
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
(Assignee)

Comment 5

13 years ago
This bug is fixed by the patch in bug #295088
Depends on: 295088

Updated

13 years ago
Assignee: mail → hyc
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED

Comment 6

13 years ago
*** Bug 154867 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
*** Bug 232455 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Keywords: perf

Comment 8

12 years ago
Regarding comment 5:
Assuming the patch in bug #295088 has been applied to Thunderbird 1.5, it did not fix this bug. Any search including a Body condition is still extremely slow, even if ANDed with a cheap condition that's never fulfilled.

Comment 9

12 years ago
this is fixed on the trunk and the 2.0 branch. The fix is not in 1.5
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.