All windows are tiny, not much bigger than a thin line

RESOLVED DUPLICATE of bug 167663

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 167663
16 years ago
13 years ago

People

(Reporter: Markus Haenchen, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.21; Mac_PowerPC)
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.1/mozilla-macosX-1.1.smi.bin

Mac OS X 10.2, Pismo, Mozilla 1.1, 
All windows opened in Mozilla are tiny, just a line, you can drag them, close them (command-W) but that's it.
A screen shot can be seen at (http://n.ethz.ch/students/hamarkus/mozilla_window_bug.jpg)
This first happened when visiting the following URL (accessed from a bookmark) http://212.74.180.17/direct/
ecoute.htm , I accessed this webpage before (that's how I bookmarked it), but that may have been with an 
earlier version of Mozilla (or Mac OS), I don't know. I tried reinstalling, to no avail. 

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla (since Mozilla opens a new window upon start-up, that's it)
2.
3.

Actual Results:  
A tiny window, or rather a line representing the window appears, see http://n.ethz.ch/students/hamarkus/
mozilla_window_bug.jpg

Comment 1

16 years ago
Note that the correct screenshot link is:
http://n.ethz.ch/student/hamarkus/mozilla_window_bug.jpg

The referenced website includes script to reposition the window:
window.moveTo(650, 0)

Is this what caused the problem?

Comment 2

16 years ago
Markus, can you reproduce this problem using another Mozilla user profile?
Severity: blocker → major

Comment 3

16 years ago
I had this problem on Win2k once.  I uninstalled, deleted the Mozilla.org folder
and cleaned up the registry.  An install of the 1.1 release worked fine after that.
(Reporter)

Comment 4

16 years ago
Creating a new user 'solves' the problem.
I copied, bookmarks.html, cookies.txt, cookperm.txt, Netscape Preferences, prefs.bak and prefs.js over to 
the new user folder in Library to get the bookmarks, the toolbar, the preferences and the cookies from the 'old' 
user. Everything works fine for the new user (although the saved passwords were lost). But the old user still 
has the same problem. 

Comment 5

16 years ago
Bug 167663, bug 166519, bug 167545, and bug 166963 all seem to be the same 
problem (window shrinks to an extremely small size under OS X 10.2).

Arbitrarily marking the last three as duplicates of the first one.


*** This bug has been marked as a duplicate of 167663 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

16 years ago
The bug 'happened' again, with the same web page as the first time, although I
visited this web page several times inbetween without having any problems. 

Creating a new profile solved it. Tracking all files in the user profile folder,
I found out that the file 'localstore.rdf' is the culprit. Copying the file from
a affected user profile to a new one, made the new profile have the same
problems. Taking a fresh 'localstore.rdf' from a new profile and replacing with
it the corresponding file in an affected user profile fixed the problem in the
affected profile. 

Unfortunately, I accidentily deleted the corrupted localstore.rdf file. 

And, I cannot reproduce Bug[167663] on my computer. 

Comment 7

16 years ago
localstore.rdf is the file that (IIRC) stores persisted window sizes/positions,
which would explain why replacing it fixes the problem.

If you cannot reproduce bug 167663, we could reopen this one, but if you can't
reproduce this one either, we'll just have to close this one as WORKSFORME. 
There doesn't seem to be much point, so leaving it duplicated to bug 167663 for now.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.