Closed Bug 1665735 Opened 3 years ago Closed 14 days ago

[KDE] Middle click on titlebar doesn't work with custom titlebar rendering

Categories

(Core :: Widget: Gtk, defect, P3)

All
Linux
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr102 --- unaffected
firefox82 --- wontfix
firefox113 --- wontfix
firefox114 --- fix-optional
firefox115 --- affected

People

(Reporter: dennis, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

I have set my KDE desktop to move a window into the background when right-clicking its titlebar. When the new titlebar rendering (bug 1283299) is enabled, that doesn't work anymore.

The bug has a release status flag that shows some version of Firefox is affected, thus it will be considered confirmed.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: gtktitlebar
Severity: -- → S3
Priority: -- → P3
Keywords: regression
Regressed by: 1812289

Set release status flags based on info from the regressing bug 1812289

:emilio, since you are the author of the regressor, bug 1812289, could you take a look?

For more information, please visit BugBot documentation.

There's no real way of fixing this that I'm aware of. We do want to show our own context menu when right-clicking in the titlebar, and I fixed plasma to show the native menu when right clicking again (https://bugs.kde.org/show_bug.cgi?id=454756). I think this is the best we can do with CSD.

Status: NEW → RESOLVED
Closed: 14 days ago
Flags: needinfo?(emilio)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.