The default bug view has changed. See this FAQ.

Links referencing local objects does not work when served from remote web server

RESOLVED DUPLICATE of bug 84128

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 84128
15 years ago
13 years ago

People

(Reporter: Darrell Russell, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0 (CK-SillyDog)
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826

HTML links referencing local objects in html pages created and served from web
server do not work. It used to work in old versions and works in other browsers.
(Same problem in mail) Link can be manually copied and pasted in URL window to
make this work, so the problem is it won't do this automatically as it should.
This is a serious problem for Intranets who would like to upgrade to this
browser, as all files on shared network must be published on Web Server to be
successfully linked and this is not practical!


Reproducible: Always

Steps to Reproduce:
1.Serve out web page with link to object located on shared network
2.Access web page served out to Intranet.
3.Tapping on link.

Actual Results:  
Nothing happens, link will not perform.
Copying and pasting in URL window will allow link to to work.

Expected Results:  
Tapping on link should have opened object in browser window.
Note: This same problem exists in Mail.

This type of link always works in older browsers such as Netscape v4.8 and
also works in competition's browsers.
see Tools/Web Development/Javascript Console.

You can allow this in your installation with a hidden pref.


*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.