Closed Bug 1665860 Opened 1 year ago Closed 1 year ago

2.06 - 5.85% Explicit Memory / Resident Memory (linux1804-64-shippable, macosx1014-64-shippable, windows10-64-shippable, windows10-64-shippable-qr, windows7-32-shippable) regression on push 6450088b6b73ffc17c79cd7097b1bfe30d00e207 (Mon September 14 2020)

Categories

(Core :: XPCOM, defect)

Firefox 82
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- wontfix
firefox81 --- wontfix
firefox82 --- wontfix

People

(Reporter: Bebe, Unassigned)

References

(Regression)

Details

(Keywords: perf, perf-alert, regression)

Perfherder has detected a awsy performance regression from push 6450088b6b73ffc17c79cd7097b1bfe30d00e207. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

6% Explicit Memory windows7-32-shippable opt 263,156,373.59 -> 278,547,344.72
4% Explicit Memory windows10-64-shippable opt 332,548,021.13 -> 347,143,002.16
4% Explicit Memory windows10-64-shippable-qr opt 351,797,740.90 -> 367,002,442.63
4% Explicit Memory linux1804-64-shippable opt 351,700,903.34 -> 365,480,947.30
3% Explicit Memory macosx1014-64-shippable opt 371,143,891.74 -> 383,912,018.81
3% Explicit Memory linux1804-64-shippable opt tp6 468,295,047.35 -> 484,334,960.82
3% Explicit Memory macosx1014-64-shippable opt tp6 479,081,782.33 -> 492,614,355.61
2% Resident Memory windows10-64-shippable-qr opt 554,859,955.87 -> 567,117,522.32
2% Resident Memory linux1804-64-shippable opt tp6 724,408,665.13 -> 739,365,051.47

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Component: Performance → XPCOM
Flags: needinfo?(dothayer)
Product: Testing → Core

Yeah - that all makes sense. Ultimately though the patches in bug 1656261 are a backout of recent startupcache work though, so this is only sort of a regression. That work never made it to release.

Flags: needinfo?(dothayer)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1664256
You need to log in before you can comment on or make changes to this bug.