Closed Bug 1666064 Opened 1 year ago Closed 23 days ago

[Windows 7] Set Firefox as default browser also sets it as default PDF viewer and does not confirm despite the use of ellipsis on the button

Categories

(Firefox :: Shell Integration, defect, P3)

Firefox 81
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: human.peng, Unassigned)

References

(Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36

Steps to reproduce:

Click "Make default..."

Actual results:

It not only changes Firefox as my default web browser, it also overrides my default PDF viewer (Adobe Acrobat).

Expected results:

It should only change the default for web browsing, not PDF viewing.

Also, the button for this action is "Make default...", with three dots, but it directly changes your default. This violates the convention that if a button has "...", it means it should open an dialog instead of making change directly.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → PDF Viewer
Component: PDF Viewer → File Handling

I'm fairly sure that the PDF thing is deliberate - Nick, can you comment on how this works?

As for the ellipsis, it's because on Windows 10, we cannot change the defaults ourselves and will open a Windows settings dialog. We haven't come up with separate labels to use on Windows 7 and Windows 10 just to remove the ellipsis...

Blocks: 1506416
Component: File Handling → Shell Integration
Flags: needinfo?(nalexander)
Summary: Set Firefox as default browser also set it as default PDF viewer → [Windows 7] Set Firefox as default browser also sets it as default PDF viewer and does not confirm despite the use of ellipsis on the button

Just tried it on Win 10, AFAIK, Windows settings' "web browser" option will only change the web browser, not PDF viewer.

Is there a reason why it does so on Win7, if it's deliberate?

(In reply to fireattack from comment #3)

Just tried it on Win 10, AFAIK, Windows settings' "web browser" option will only change the web browser, not PDF viewer.

Thanks for testing this.

Is there a reason why it does so on Win7, if it's deliberate?

It's not deliberate, AFAIK.

I think this is probably fallout from Bug 1506416, which made it possible to set Firefox as the default PDF viewer. But it looks like on Windows 7 we go through the same code path as Bug 1652412, which makes "Set as Default" set Firefox as the default PDF viewer as well, which isn't deliberate.

My guess is that addressing Bug 1652412 will fix this issue; I will take that ticket.

Flags: needinfo?(nalexander)
Regressed by: 1506416
Has Regression Range: --- → yes
Severity: -- → S3
Priority: -- → P3

I believe this to have been closed by Bug 1652412.

Status: NEW → RESOLVED
Closed: 23 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.