Closed Bug 1666357 Opened 4 years ago Closed 4 years ago

Add radiogroups to VoiceOver Rotor

Categories

(Core :: Disability Access APIs, defect, P1)

Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
83 Branch
Tracking Status
firefox83 --- verified

People

(Reporter: morgan, Assigned: morgan)

References

Details

Attachments

(1 file)

STR:

  1. Lauch VO on data:text/html,<div role="radiogroup"><div role="radio">I agree</div></div>
  2. VO+U to radiogroup rotor

Expected:
VO lists the radiogroup

Actual:
nothing

Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9cdbf4e04e19
Add AXRadioGroupSearchKey support to VO rotor
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/919cec7266b7
Add AXRadioGroupSearchKey support to VO rotor
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
Flags: needinfo?(mreschenberg)
Flags: qe-verify+

I have reproduced the issue by following the steps from comment 0, an on affected Nightly build, 82.0a1 (20200914212941).

The issue is verified as fixed on latest Beta 83.0b4, under macOS 10.15

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: