Closed Bug 1666479 Opened 1 year ago Closed 1 year ago

Perma [Late Beta] TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register.html | could not register for push notification when Gecko 83 merges to Beta on 2020-10-19

Categories

(Testing :: web-platform-tests, defect)

defect

Tracking

(firefox-esr78 unaffected, firefox80 unaffected, firefox81 unaffected, firefox82 unaffected, firefox83 affected)

RESOLVED DUPLICATE of bug 1666471
Tracking Status
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- unaffected
firefox82 --- unaffected
firefox83 --- affected

People

(Reporter: apavel, Unassigned)

References

(Regression)

Details

Central as Beta simulation

Treeherder link: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cusercancel%2Crunnable&revision=af901d1731ce3741c297dd7020758faa11f550cb&searchStr=mochitest%2Cplain&selectedTaskRun=W8kTZcfoQvuLwtD3VfCp1g.0

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=316372342&repo=try&lineNumber=4582

[task 2020-09-22T12:29:03.506Z] 12:29:03 INFO - TEST-START | dom/push/test/test_multiple_register.html
[task 2020-09-22T12:29:03.506Z] 12:29:03 INFO - GECKO(1705) | JavaScript error: , line 0: uncaught exception: UnknownError
[task 2020-09-22T12:29:03.548Z] 12:29:03 INFO - TEST-INFO | started process screencapture
[task 2020-09-22T12:29:03.686Z] 12:29:03 INFO - TEST-INFO | screencapture: exit 0
[task 2020-09-22T12:29:03.686Z] 12:29:03 INFO - Buffered messages logged at 12:29:03
[task 2020-09-22T12:29:03.687Z] 12:29:03 INFO - TEST-PASS | dom/push/test/test_multiple_register.html | getEndpoint should return null when app not subscribed.
[task 2020-09-22T12:29:03.687Z] 12:29:03 INFO - Buffered messages finished
[task 2020-09-22T12:29:03.687Z] 12:29:03 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register.html | could not register for push notification
[task 2020-09-22T12:29:03.687Z] 12:29:03 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2020-09-22T12:29:03.687Z] 12:29:03 INFO - setupPushNotification/p</<@dom/push/test/test_multiple_register.html:55:13
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register.html | Some test failed with error TypeError: can't access property "swr", result is null
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - runTest/<@dom/push/test/test_multiple_register.html:122:9
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register.html | This test left a service worker registered without cleaning it up
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - afterCleanup@SimpleTest/SimpleTest.js:1542:18
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register.html | Left over worker: http://mochi.test:8888/tests/dom/push/test/worker.js?0.4070872268509568 (scope: http://mochi.test:8888/tests/dom/push/test/)
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2020-09-22T12:29:03.688Z] 12:29:03 INFO - afterCleanup@SimpleTest/SimpleTest.js:1547:20
[task 2020-09-22T12:29:03.689Z] 12:29:03 INFO - GECKO(1705) | MEMORY STAT | vsize 6662MB | residentFast 83MB | heapAllocated 12MB
[task 2020-09-22T12:29:03.689Z] 12:29:03 INFO - TEST-OK | dom/push/test/test_multiple_register.html | took 91ms
[task 2020-09-22T12:29:03.689Z] 12:29:03 ERROR - TEST-UNEXPECTED-FAIL | /tests/dom/push/test/test_multiple_register.html logged result after SimpleTest.finish(): This test left a service worker registered without cleaning it up
[task 2020-09-22T12:29:03.689Z] 12:29:03 ERROR - TEST-UNEXPECTED-FAIL | /tests/dom/push/test/test_multiple_register.html logged result after SimpleTest.finish(): Left over worker: http://mochi.test:8888/tests/dom/push/test/worker.js?0.4070872268509568 (scope: http://mochi.test:8888/tests/dom/push/test/)
[task 2020-09-22T12:29:03.689Z] 12:29:03 INFO - TEST-START | dom/push/test/test_multiple_register_different_scope.html
[task 2020-09-22T12:29:03.689Z] 12:29:03 INFO - GECKO(1705) | JavaScript error: , line 0: uncaught exception: UnknownError
[task 2020-09-22T12:29:03.694Z] 12:29:03 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-09-22T12:29:03.694Z] 12:29:03 INFO - Buffered messages logged at 12:29:03
[task 2020-09-22T12:29:03.698Z] 12:29:03 INFO - TEST-PASS | dom/push/test/test_multiple_register_different_scope.html | getEndpoint should return null when app not subscribed.
[task 2020-09-22T12:29:03.698Z] 12:29:03 INFO - Buffered messages finished
[task 2020-09-22T12:29:03.698Z] 12:29:03 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register_different_scope.html | could not register for push notification
[task 2020-09-22T12:29:03.698Z] 12:29:03 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2020-09-22T12:29:03.698Z] 12:29:03 INFO - getEndpointExpectNull/<@dom/push/test/test_multiple_register_different_scope.html:75:11
[task 2020-09-22T12:29:03.698Z] 12:29:03 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-09-22T12:29:03.699Z] 12:29:03 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register_different_scope.html | Some test failed with error AbortError: Error retrieving push subscription.
[task 2020-09-22T12:29:03.699Z] 12:29:03 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2020-09-22T12:29:03.699Z] 12:29:03 INFO - runTest/<@dom/push/test/test_multiple_register_different_scope.html:113:9
[task 2020-09-22T12:29:03.713Z] 12:29:03 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-09-22T12:29:03.713Z] 12:29:03 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register_different_scope.html | This test left a service worker registered without cleaning it up
[task 2020-09-22T12:29:03.713Z] 12:29:03 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2020-09-22T12:29:03.713Z] 12:29:03 INFO - afterCleanup@SimpleTest/SimpleTest.js:1542:18
[task 2020-09-22T12:29:03.713Z] 12:29:03 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-09-22T12:29:03.713Z] 12:29:03 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register_different_scope.html | Left over worker: http://mochi.test:8888/tests/dom/push/test/worker.js?0.22464695612337704 (scope: http://mochi.test:8888/tests/dom/push/test/b/)
[task 2020-09-22T12:29:03.714Z] 12:29:03 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2020-09-22T12:29:03.714Z] 12:29:03 INFO - afterCleanup@SimpleTest/SimpleTest.js:1547:20
[task 2020-09-22T12:29:03.714Z] 12:29:03 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-09-22T12:29:03.715Z] 12:29:03 INFO - TEST-UNEXPECTED-FAIL | dom/push/test/test_multiple_register_different_scope.html | Left over worker: http://mochi.test:8888/tests/dom/push/test/worker.js?0.6405073781160625 (scope: http://mochi.test:8888/tests/dom/push/test/a/)
[task 2020-09-22T12:29:03.715Z] 12:29:03 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2020-09-22T12:29:03.715Z] 12:29:03 INFO - afterCleanup@SimpleTest/SimpleTest.js:1547:20
[task 2020-09-22T12:29:03.746Z] 12:29:03 INFO - GECKO(1705) | MEMORY STAT | vsize 6664MB | residentFast 85MB | heapAllocated 11MB
[task 2020-09-22T12:29:03.746Z] 12:29:03 INFO - TEST-OK | dom/push/test/test_multiple_register_different_scope.html | took 161ms
[task 2020-09-22T12:29:03.747Z] 12:29:03 ERROR - TEST-UNEXPECTED-FAIL | /tests/dom/push/test/test_multiple_register_different_scope.html logged result after SimpleTest.finish(): This test left a service worker registered without cleaning it up
[task 2020-09-22T12:29:03.747Z] 12:29:03 ERROR - TEST-UNEXPECTED-FAIL | /tests/dom/push/test/test_multiple_register_different_scope.html logged result after SimpleTest.finish(): Left over worker: http://mochi.test:8888/tests/dom/push/test/worker.js?0.22464695612337704 (scope: http://mochi.test:8888/tests/dom/push/test/b/)
[task 2020-09-22T12:29:03.747Z] 12:29:03 ERROR - TEST-UNEXPECTED-FAIL | /tests/dom/push/test/test_multiple_register_different_scope.html logged result after SimpleTest.finish(): Left over worker: http://mochi.test:8888/tests/dom/push/test/worker.js?0.6405073781160625 (scope: http://mochi.test:8888/tests/dom/push/test/a/)

James please take a look.

Flags: needinfo?(james)
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(james)
Resolution: --- → DUPLICATE
Duplicate of bug: 1666471
You need to log in before you can comment on or make changes to this bug.