Closed Bug 1667281 Opened 1 year ago Closed 1 year ago

Replaced element's content ratio is affected by aspect-ratio property, resulting broken "object-fit: contain"

Categories

(Core :: Layout, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1660122
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- wontfix
firefox82 --- wontfix
firefox83 --- fixed

People

(Reporter: TYLin, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

By looking at the aIntrinsicRatio argument passing to nsLayoutUtils::ComputeObjectDestRect, which is influenced by aspect-ratio, I think nsImageFrame, nsHTMLCanvasFrame, and nsSubDocumentFrame might be affected.

Attached file replaced-element-022.tentative.html (obsolete) —

A testcase for <canvas> with object-fit: contain.

Update the testcase.

Attachment #9177788 - Attachment is obsolete: true

This is going to be fixed by bug 1660122 Part 7 (https://phabricator.services.mozilla.com/D91229), so I'll close this as duplicate of bug 1660122.

Severity: -- → S3
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1660122
You need to log in before you can comment on or make changes to this bug.