Closed Bug 1667648 Opened 9 months ago Closed 9 months ago

autocomplete with Lightning is wrong when comment column is enabled

Categories

(Calendar :: General, defect)

Thunderbird 78
defect

Tracking

(thunderbird_esr78+ fixed, thunderbird82 fixed)

RESOLVED FIXED
83 Branch
Tracking Status
thunderbird_esr78 + fixed
thunderbird82 --- fixed

People

(Reporter: cardbook.thunderbird, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Whiteboard: [invite attendees dialog])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

set mail.autoComplete.commentColumn to 1
go to Lightning, create an event and try to add one attendee, the email autocompletion is wrong, you only see the address book name, not the emails...

Actual results:

Expected results:

see emails plus address book names (like in email autocompletion)

Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 78 → Thunderbird 78

In my 78.3.0 the default is "mail.autoComplete.commentColumn;0".

Does the CardBook extension change that to a "1", and why is it needed?

If I change it to a "1", and try to invite attendees, all I see now is address book names without the extension.

Flags: needinfo?(cardbook.thunderbird)

CardBook does not change the mail.autoComplete.commentColumn option.

I do not understand why setting this option to 1 is supported when writting email and why this is not supported for adding an attendee...

Flags: needinfo?(cardbook.thunderbird)
Whiteboard: [invite attendees dialog]

I do not understand why setting this option to 1 is supported when writting email and why this is not supported for adding an attendee...

Perhaps it's because the developer has never come across this preference before.

Status: UNCONFIRMED → NEW
Ever confirmed: true

We should figure out how to make this widget self-contained as Firefox does, but for now I just want to fix the bug with a simple patch that can be uplifted.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Target Milestone: --- → 83 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/860c58cae454
Copy auto-complete drop-down styles into event attendees dialog. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/31641628ab4e
follow-up - Fix bad CSS selector. rs=bustage-fix DONTBUILD

Comment on attachment 9178137 [details]
Bug 1667648 - Copy auto-complete drop-down styles into event attendees dialog. r?Paenglab

[Approval Request Comment]
Regression caused by (bug #): bug 1639763
User impact if declined: users with a pref set can't see the most important info in a dialog
Testing completed (on c-c, etc.): on c-c for a week
Risk to taking this patch (and alternatives if risky):

Attachment #9178137 - Flags: approval-comm-beta?

Comment on attachment 9178137 [details]
Bug 1667648 - Copy auto-complete drop-down styles into event attendees dialog. r?Paenglab

[Triage Comment]
Approved for beta

Attachment #9178137 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #9178137 - Flags: approval-comm-esr78?

Comment on attachment 9178137 [details]
Bug 1667648 - Copy auto-complete drop-down styles into event attendees dialog. r?Paenglab

[Triage Comment]
Approved for esr78

Attachment #9178137 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.