Closed Bug 1667805 Opened 1 year ago Closed 1 year ago

Tab sound indicator overlaps the previous tab when play video in PiP player

Categories

(Firefox :: Tabbed Browser, defect)

Firefox 83
Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
83 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- unaffected
firefox82 --- unaffected
firefox83 --- verified

People

(Reporter: alice0775, Assigned: baumga91)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

Attached image screenshot

If favicon is not provided, tab sound indicator overlaps the previous tab.

STR:

  1. Play local mp4 video
  2. View the video in PiP player

Actual results:
Tab sound indicator overlaps the previous tab
See attached screenshot.

Expected Results:
Tab sound indicator should not overlap the previous tab

Ooof, looks like we missed a nasty case here (no favicon). Perhaps we can How should the speaker be positioned in this case, emanuela? Perhaps we can show the "world" default icon in the event that PiP is enabled like we do when we're pinned?

Flags: needinfo?(emanuela)

Great idea, Mike. Let's use the default icon

Flags: needinfo?(emanuela)
Assignee: nobody → baumga91

Do you have time to look at this one, Niklas?

Flags: needinfo?(baumga91)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #3)

Do you have time to look at this one, Niklas?

Yes, I can work on this

Flags: needinfo?(baumga91)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c0549adf92eb
Adding default favicon to tabs that don't have favicon when using PiP. r=Gijs
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch

Alice, could you confirm if this is fixed on today's nightly? Thank you!

Flags: needinfo?(alice0775)

(In reply to :Gijs (he/him) from comment #9)

Alice, could you confirm if this is fixed on today's nightly? Thank you!
Yes, this was fixed.
I can no longer reproduce the issue on Nightly83.0a1(20200929094055).

Flags: needinfo?(alice0775)

Thank you!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.