[Fixed by new Profile] tvguide.com show descriptions show blank window

VERIFIED INVALID

Status

SeaMonkey
Preferences
VERIFIED INVALID
16 years ago
13 years ago

People

(Reporter: slice1900, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Using Mozilla 1.1 release on Redhat 7.2, I have seen this problem for some time,
dating back a number of point releases.  To reproduce, visit the above URL,
www.tvguide.com/listings, and enter your info.  When it shows the show listings,
choose a show and click on it.  Expected behavior is to pop up a window showing
a synopsis of the show.  Actual behavior is that a blank window pops up.  It is
of the correct size, so the pop up protection isn't preventing it like it did
after that feature was added.  I kept assuming it was some problem that surely
affected other sites and thus didn't worry about it, but maybe there is
something odd about what tvguide is doing that makes it a problem that doesn't
affect many other sites.

This is one of the few remaining bugs that prevents me from deleting Netscape
4.x from my system forever.  Its painful to do this since I'm so used to
Mozilla's quick rendering of tables, watching Netscape 4.x struggle to do it
hurts me :)
Are there any errors in the JS console?  (I cannot reproduce the problem with
linux trunk build 2002-09-03-22, with popup blocking either on or off).

Comment 2

16 years ago
I also get a blank popup window, with the following in the JS console:
Error: uncaught exception: Permission denied to call method Window.focus

I fixed it by removing the following line from my prefs.js:
user_pref("capability.policy.default.Window.focus", "noAccess");

which seems to be a remnant of some older pref naming scheme, since I "Allow
scripts to" do everything under Advanced | Scripts & Plugins
and still had that line...

Make sure you exit Mozilla and make a backup copy of prefs.js before changing it.

Comment 3

16 years ago
Browser, not engine ---> Prefs component.
Mats: thanks for that explanation.
                                                                                          
slice1900@hotmail.com: are you also getting the same error in 
Tools > Web Development > JavaScript Console? 
(be sure to clear it of any previous errors first)

If so, you can edit your prefs.js file (or "user.js", or "all.js")
to remove the line Mats has indicated. Alternatively, you could
just edit that line to say "allAccess" instead of "noAccess".

If you prefer, you could simply create a brand-new Mozilla profile.
Note, if the Profile Manager doesn't automatically come up when you 
start Mozilla, you can force it to come up by launching Mozilla
from the command line like this:

      [(path to Mozilla)] ./mozilla -profilemanager

Either way, once the Profile Manager comes up, click on
"Create Profile". If you run Mozilla under the new profile,
the problem should go away, too.

Of course, if neither of these approaches fixes the problem
please let us know and we'll try to figure out what to do next -
Assignee: rogerl → ben
Component: JavaScript Engine → Preferences
QA Contact: pschwartau → sairuh
Summary: tvguide.com show descriptions show blank window → [Fixed by new Profile] tvguide.com show descriptions show blank window
(Reporter)

Comment 4

16 years ago
Bingo!  That fixed it.  I also had that line in my prefs.js, and I know where it
came from.  Some time ago before the addition of the interface for disabling pop
up and other bad mojo from evil javascripters, I saw something indicating that
this would be good to add to my prefs.js (I think there was another line or two
dealing with open windows)

user_pref("capability.policy.default.Window.defaultStatus", "noAccess");
user_pref("capability.policy.default.Window.focus", "noAccess");
user_pref("capability.policy.default.Window.innerHeight.set", "noAccess");
user_pref("capability.policy.default.Window.innerWidth.set", "noAccess");
user_pref("capability.policy.default.Window.moveBy", "noAccess");
user_pref("capability.policy.default.Window.moveTo", "noAccess");
user_pref("capability.policy.default.Window.outerHeight.set", "noAccess");
user_pref("capability.policy.default.Window.outerWidth.set", "noAccess");
user_pref("capability.policy.default.Window.resizeBy", "noAccess");
user_pref("capability.policy.default.Window.resizeTo", "noAccess");
user_pref("capability.policy.default.Window.screenX.set", "noAccess");
user_pref("capability.policy.default.Window.screenY.set", "noAccess");
user_pref("capability.policy.default.Window.sizeToContent", "noAccess");
user_pref("capability.policy.default.Window.status", "noAccess");

The second line is the offending line I removed, everything else is left in
there.  As I currently allow scripts to do everything except open unrequested
windows, I suppose the rest of that stuff can be deleted, since it is all
covered by the checkboxes where I'm (supposedly) allowing scripts to do these
things?

Anyway, this can be resolved, and thanks go to Mats for his quick fix less than
5 hours after I posted the bug!
everything is working as it's supposed to,then.  ;)
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
I would recommend removing the rest of the lines above too.

1. exit Mozilla and make backup copy of prefs.js
2. remove the lines listed above
3. start Mozilla and set the "Scripts & Plugins" prefs as you want them

Good luck


(This bug isn't really invalid, but what the heck - problem solved: verified)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.