Closed Bug 166821 Opened 18 years ago Closed 18 years ago

reports.cgi broken by recent schema changes

Categories

(Bugzilla :: Reporting/Charting, defect)

2.17
defect
Not set
major

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: justdave, Assigned: gerv)

References

()

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

reported to webmaster@bugzilla.org:

http://landfill.bugzilla.org/bugzilla-tip/reports.cgi?product=FoodReplicator&output=most_recently_doomed&links=1&banner=1

2002-10-05 14:50 GMT+2
Software error:

SELECT defaultmilestone FROM products WHERE product = 'FoodReplicator':
Unknown column 'product' in 'where clause' at globals.pl line 250.
I believe this is bbaetz' work...

Gerv
Assignee: gerv → bbaetz
Bleh.

I'm not going to get to this for a while - it just needs to be using aproduct_id
instead...
Keywords: regression
Target Milestone: --- → Bugzilla 2.18
Attached patch Patch v.1 (obsolete) — Splinter Review
Fixes problem, and also removes hard-coded product names (which is another bug
somewhere.)

Gerv
Comment on attachment 98363 [details] [diff] [review]
Patch v.1

The bugs.product_id=products.id join needs to be in the query always, else you
get $numbugs*$numprocucts results. Teh distinct will filter them out, but it
will still suck perf-wise.
Attachment #98363 - Flags: review-
Attached patch Patch v.2Splinter Review
Here you go... but there are other examples of that problem in this file too.

Gerv
Attachment #98363 - Attachment is obsolete: true
Comment on attachment 98405 [details] [diff] [review]
Patch v.2

But thats OK, because you're rewriting this file :)

I don't suppose you can explain why the status whiteboard needs to be empty for
this query, can you? (Don't change it, I'm just curious...)

r=bbaetz x2
Attachment #98405 - Flags: review+
-> gerv
Assignee: bbaetz → gerv
> I don't suppose you can explain why the status whiteboard needs to be empty for
> this query, can you? (Don't change it, I'm just curious...)

Presumably it's to do with the bugs being "untouched" or something.

Fixed.

Checking in reports.cgi;
/cvsroot/mozilla/webtools/bugzilla/reports.cgi,v  <--  reports.cgi
new revision: 1.58; previous revision: 1.57
done

Gerv
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.