Closed Bug 1668408 Opened 2 years ago Closed 1 year ago

DFPI breaks stackblitz.com

Categories

(Core :: Privacy: Anti-Tracking, defect, P2)

defect

Tracking

()

VERIFIED FIXED
94 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- verified

People

(Reporter: emilio, Assigned: twisniewski)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

ER:

  • A green square.

AR:

  • Right tab doesn't load, there's a cross-origin error there.

This breakage can be fixed by changing cookiebehavior to 4, so this is only related to dFPI.

Blocks: dfpi-breakage
No longer blocks: DynamicFirstPartyIsolation
Severity: -- → S3
Priority: -- → P2

It looks like the right tab is put under a third-party iframe https://rxjs-yo2jz5.stackblitz.io and its storage is partitioned. And it needs storage access to show the content properly.

I think the proper solution is to ask the website to use the StorageAccessAPI.

Steve, do you know if we have contacted them about this issue? Thanks.

Flags: needinfo?(senglehardt)

As far as I know we have not. We'll have to see if stpeter or webcompat folks have a contact.

Flags: needinfo?(senglehardt)

Filed an issue on their GitHub repo: https://github.com/stackblitz/core/issues/1374

Duplicate of this bug: 1711698
Duplicate of this bug: 1715206
Blocks: 1720140
Assignee: nobody → twisniewski
Status: NEW → ASSIGNED
Pushed by twisniewski@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f1b824815906
Work around site breakage on StackBlitz related to dFPI, by using SmartBlock shims to disable service workers; r=pbz,ksenia,webcompat-reviewers
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Verified as fixed on the latest Nightly 95.0a1 and on Firefox 94 beta 1 (having the pref network.cookie.cookieBehavior set to 5) - the green square is properly displayed on stackblitz.com.
Tested on Windows 10 x64, Ubuntu 20.04 x64, and macOS Big Sur 11.6.

Status: RESOLVED → VERIFIED
Has Regression Range: --- → yes

StackBlitz staffer here. Sorry if this is not the right venue, but is there a way for us to test in Firefox without this shim?

We have features that are breaking because of it (e.g. https://github.com/stackblitz/core/issues/1679 and a bunch of duplicate reports), because they rely on Service Workers, and we can't test fixes in Firefox because the shim seems to apply no matter what.

I tried setting a few about:config settings, but am not seeing a difference. I’m still getting a warning in the Console with

Service Workers are disabled by Firefox on this page to prevent breakage. See https://bugzilla.mozilla.org/show_bug.cgi?id=1668408 for details.

The about:config options I tried (in Firefox Nightly and stable) were:

  • extensions.webcompat.enable_shims = false
  • extensions.webcompat.perform_injections = false
  • extensions.webcompat.perform_ua_overrides = false
Flags: needinfo?(twisniewski)

(In reply to Florens Verschelde :fvsch from comment #11)

StackBlitz staffer here. Sorry if this is not the right venue, but is there a way for us to test in Firefox without this shim?

We have features that are breaking because of it (e.g. https://github.com/stackblitz/core/issues/1679 and a bunch of duplicate reports), because they rely on Service Workers, and we can't test fixes in Firefox because the shim seems to apply no matter what.

I tried setting a few about:config settings, but am not seeing a difference. I’m still getting a warning in the Console with

Service Workers are disabled by Firefox on this page to prevent breakage. See https://bugzilla.mozilla.org/show_bug.cgi?id=1668408 for details.

The about:config options I tried (in Firefox Nightly and stable) were:

  • extensions.webcompat.enable_shims = false
  • extensions.webcompat.perform_injections = false
  • extensions.webcompat.perform_ua_overrides = false

Navigate to about:compat and click "Disable" for StackBlitz. That should disable the shim for the current browser session.

Flags: needinfo?(twisniewski)

Thanks a bunch :)

You need to log in before you can comment on or make changes to this bug.