Closed Bug 1668904 Opened 4 years ago Closed 3 years ago

Calendar event display issue: event Location text not constrained to within graphical event block

Categories

(Calendar :: Calendar Frontend, defect)

Thunderbird 78
Desktop
All
defect

Tracking

(thunderbird_esr78 wontfix)

RESOLVED FIXED
90 Branch
Tracking Status
thunderbird_esr78 --- wontfix

People

(Reporter: davelabrecque, Assigned: henry-x)

References

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Safari/537.36

Steps to reproduce:

In TB 78.3.1 (x64) create an event. Give it a title and fill in the Location field with a text string. Close the Edit Event dialog.

Actual results:

Depending on the duration of the event and the size/scale/resolution settings of your calendar window and monitor, the Location text string is visible either inside the event block, outside of the block, or straddling the lower border of the block. If the text is white, the portion of it below the graphical event block can be barely visible or invisible.

Expected results:

Location text should only display if there is enough vertical space in the graphical event block to contain it.

Using your example and creating the event to last a half hour, all the text beyond https://us02web.zoom.us disappears for me using 78.3.1 on Ubuntu 18.04 LTS with a 19" monitor.

If I change the event to last an hour all is visible in the event in Day view. It does wrap after https://us02web.zoom.us

I don't see anything showing outside the block.
I'll test on my Windows10 laptop.

Component: Untriaged → General
OS: Unspecified → Windows 10
Product: Thunderbird → Calendar
Hardware: Unspecified → Desktop
Version: 78 → unspecified

Testing with 78.3.1 on Windows10, I can get a faded text in the event block if I place the URL in the Location field.

I put it all in the Title field in my test on Linux. Sorry for that mistake.

Tell us what you mean by "faded." Can you get it to extend beyond the bottom of the event "block" on the calendar one-day view if the event is short enough in duration?

Attached image faded_text.png

(In reply to davelabrecque from comment #3)

Tell us what you mean by "faded." Can you get it to extend beyond the bottom of the event "block" on the calendar one-day view if the event is short enough in duration?

Yes, I can if the duration is 15 minutes.

I can get it to look like your screenshot with a duration of 40 minutes.

Attached image dark-theme.png

Using the Thunderbird Dark theme.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 10 → All
Version: unspecified → Thunderbird 78
Component: General → Calendar Frontend

I just had a look at 68.10.0 on Ubuntu to see how it appears, and the Location information doesn't appear in the event block in Day view even with an hour or two hour long duration. Just the event title.

It does in the tooltip along with the Title, Date/Time and Calendar.

So, I wonder if that Location information is supposed to appear at all in 78.x.x?

Appears in the block in 68.12.1, Beta 82.0b2, but not in Daily 83.0a1.

Fascinating.

Seems like it would've taken an intentional code change to make it appear. If so, it appears they need to trap for too-small a block size.

I'm new here. What happens next? Now that it's been verified, I mean?

(In reply to davelabrecque from comment #7)

Seems like it would've taken an intentional code change to make it appear. If so, it appears they need to trap for too-small a block size.

I'm new here. What happens next? Now that it's been verified, I mean?

I think the bug here is that Location does appear, shouldn't appear, and only the events Title should be appearing. The rest of the information can be seen in the tool tip.

Flags: needinfo?(paul)
Flags: needinfo?(geoff)

Showing the location has been an option since forever. (I didn't know it was a thing either.) You can turn it on or off from the preferences UI.

I'm not sure why it's started overflowing but my bet would be something to do with the layout code rather than a change in the calendar. I guess the thing to do is to constrain the box holding the text and if it overflows that's tough.

(Leaving myself needinfo'ed so I remember to come back to this, but clearing Paul as he's not here any more.)

Flags: needinfo?(paul)

Is this self-explanatory to code guys? I'm not a code guy. What does this code do? Does it kill text that would fall outside of (or be cut off by) the box borders by any chance?

I just pointed out where the node is filled. Someone will have to check what css is wrong exactly where.

(In reply to Magnus Melin [:mkmelin] from comment #12)

I just pointed out where the node is filled. Someone will have to check what css is wrong exactly where.

Depends on: 1694820
Assignee: nobody → henry
Status: NEW → ASSIGNED

Bug 1694820 means that the location is now vertically cropped if it does not fit.

It can still look bad if text is cropped half-way, but at least it doesn't overflow the container (I think to completely hide the location if it doesn't fit completely vertically would require some javascript). Would others consider this FIXED now?

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Would not completely fixed if one goes by the originally stated Expected Results for this bug. Perhaps considered fixed if going by the title of this bug as originally stated.

I guess I'd rather not see a fraction of the upper portion of a text string. The OP has spoken. ;)

Flags: needinfo?(geoff)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: