Closed Bug 1669696 Opened 1 year ago Closed 11 months ago

Custom margins are not applied if a second value is changed after the error message is triggered and the “trigger” value is than changed to a valid one

Categories

(Toolkit :: Printing, defect, P2)

Firefox 83
defect

Tracking

()

VERIFIED FIXED
84 Branch
Tracking Status
firefox83 --- verified
firefox84 --- verified

People

(Reporter: Anca, Assigned: emalysz)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [print2020_v83] [old-ui-])

Attachments

(2 files)

Attached image screencast issue.gif

Affected versions

  • 83.0a1 (2020-10-07)

Affected platforms

  • Windows 10
  • macOS 10.14
  • Ubuntu 18.04

Steps to reproduce

  1. Launch Fx
  2. Make sure print.tab-modal.enabled is set on true
  3. Hit Ctrl + P on any page
  4. Set an invalid value for the Left (or any other option) in order to trigger the error message
  5. Change the value for any other option (eg. Right)
  6. Change the value from step 4 to a valid one

Expected result

  • The options are validated (the red border disappear), the error message is no longer displayed, the print preview is updated according to the changes

Actual result

  • The options are validated (the red border disappear), the error message is still displayed, the print preview is not updated according to the changes

Regression range

  • Not a regression, introduced with the Custom margins functionality

Additional notes

  • Once another modification is made inside any of the field, the issue is no longer present

Suggested severity

  • S3
Assignee: nobody → emalysz
Severity: -- → S4
Priority: -- → P2
Status: NEW → ASSIGNED
Has STR: --- → yes
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b2a95a6e071
update custom margins if both values are valid r=mstriemer
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b922807f962
update custom margins if both values are valid r=mstriemer
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch

Comment on attachment 9180752 [details]
Bug 1669696: update custom margins if both values are valid

Beta/Release Uplift Approval Request

  • User impact if declined: Custom margin functionality is very buggy. They will not revalidate with new inputs
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: STR listed in comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): No string changes
  • String changes made/needed: n/a
Flags: needinfo?(emalysz)
Attachment #9180752 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9180752 [details]
Bug 1669696: update custom margins if both values are valid

Approved for 83 beta 2, thanks

Attachment #9180752 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

This issue is verified fixed with Fx 83.0b2 and Fx 84.0a1 (2020-10-20) on Windows 10, Ubuntu 18.04 and macOS 10.15.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.