track memory usage and performance via help|about

RESOLVED FIXED

Status

()

Core
XPCOM
--
enhancement
RESOLVED FIXED
15 years ago
6 years ago

People

(Reporter: Marko Macek, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
It seems mozilla still has serious memory usage problems (I just restarted after
my mozilla had VM Size of 250M, despite just having 2 browsers + mail open)

It would be very useful for bug reports to have help|about show the status of
various memory allocators (current,max allocated).

another thing would be performance of the javascript GC, mostly average/maximum
latency.

Comment 1

15 years ago
cathleen, are you interested?
Assignee: dougt → cathleen
Component: XPCOM → Networking

Comment 2

15 years ago
Is this a networking feature?

Comment 3

15 years ago
we have lots of footprint analysis/reduction work need be done.  This is a
feature, and we won't be able to get to.

i welcome any volunteers.

Comment 4

10 years ago
I don't this this is networking related. I'm setting it to XPCOM as a better choice.

I would rather see this as a component which could return information (amount of memory allocated, number of XPCOM objects, Memory cache size, ...). Then, this could be added to the UI where appropriate (or maybe just let extensions show that information).

Would the overhead of adding counters to malloc/free and XPCOM allocations be tolerable for this to be enabled in optimized builds?
Assignee: cathleennscp → nobody
Component: Networking → XPCOM
QA Contact: scc → xpcom
Summary: track memory usage and performance in Help|About. → track memory usage and performance
Summary: track memory usage and performance → track memory usage and performance via help|about

Comment 5

8 years ago
This is probably a duplicate of bug 392351 (or it could that that API to show memory information in about|help).

Comment 6

8 years ago
hrm, I can't type in this bug. s/could that that/could use that/.

Comment 7

8 years ago
Should we replicate the "about:memory" feature implemented in Google Chrome? (see attached screen shot)

Comment 8

8 years ago
Created attachment 398589 [details]
Google Chrome 3.x "about:memory" page

Updated

8 years ago
Blocks: 515354

Updated

8 years ago
No longer blocks: 515354
Depends on: 515354
about:memory is available in FireFox 3.6.3 right? But this bug still indicates NEW status!!!
We now have about:memory, and various tracking bugs for improving it further (eg. bug 563700).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.