Closed Bug 1671137 Opened 1 month ago Closed 1 month ago

Crash in [@ java.lang.ClassCastException: at org.mozilla.gecko.util.GeckoBundle.getString(GeckoBundle.java)] Crash when loading badssl http-login page

Categories

(GeckoView :: General, defect, P1)

Firefox 81
Unspecified
All

Tracking

(firefox83 fixed)

RESOLVED FIXED
83 Branch
Tracking Status
firefox83 --- fixed

People

(Reporter: berdnikov.alexandr, Assigned: esawin)

References

()

Details

(Whiteboard: [geckoview:m84])

Crash Data

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0 Safari/605.1.15

Steps to reproduce:

  1. Go to https://badssl.com/
  2. Find http-login option and click it.

You can observe this behavior in all GeckoView-based browsers so far. I see the same in Focus, Nightly and Fenix.

Actual results:

Application crashes.

Expected results:

Application must not crash.

Status: UNCONFIRMED → NEW
Crash Signature: [@ java.lang.ClassCastException: at org.mozilla.gecko.util.GeckoBundle.getString(GeckoBundle.java)]
Ever confirmed: true
Summary: Process crashes on attempt to load http-login page → Crash in [@ java.lang.ClassCastException: at org.mozilla.gecko.util.GeckoBundle.getString(GeckoBundle.java)] Crash when loading badssl http-login page
Duplicate of this bug: 1671278
Priority: -- → P1
Whiteboard: [geckoview:m84]
Assignee: nobody → esawin
Status: NEW → ASSIGNED

Kevin, I don't have sentry access, but is this really the same crash as https://github.com/mozilla-mobile/fenix/issues/14986 given the different crash stack?

Flags: needinfo?(kbrosnan)

Looks like I made a mistake I was looking for issues mentioning ClassCastException and did not look closely at the stack.

Flags: needinfo?(kbrosnan)

This looks like it's been around since 81 based on some sentry logs.

Attachment #9181867 - Attachment description: Bug 1671137 - [1.0] Only retrieve the value from HTMLInputElement instances. → Bug 1671137 - [1.1] Only retrieve the value from HTMLInputElement instances and ensure non-null strings.
Pushed by esawin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5928e980f659
[1.1] Only retrieve the value from HTMLInputElement instances and ensure non-null strings. r=geckoview-reviewers,agi
https://hg.mozilla.org/integration/autoland/rev/c0a3393e4a80
[2.0] Add Autofill crash test for the case of id='value'. r=geckoview-reviewers,agi
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch

Comment on attachment 9181867 [details]
Bug 1671137 - [1.1] Only retrieve the value from HTMLInputElement instances and ensure non-null strings.

Beta/Release Uplift Approval Request

  • User impact if declined: Crash on page load on sites containing form elements with id='value'.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Adds simple guards around using undefined/null/empty elements.
  • String changes made/needed: None
Attachment #9181867 - Flags: approval-mozilla-beta?
Attachment #9182132 - Flags: approval-mozilla-beta?

Comment on attachment 9181867 [details]
Bug 1671137 - [1.1] Only retrieve the value from HTMLInputElement instances and ensure non-null strings.

Landed in 83 nightly before the merge so we don't need to uplift to beta, thanks.

Attachment #9181867 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Attachment #9182132 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.