Closed Bug 1671341 Opened 6 months ago Closed 6 months ago

PiP will not turn off from context menu when "Enable picture-in-picture video controls" is unchecked in Preferences

Categories

(Toolkit :: Video/Audio Controls, defect)

defect

Tracking

()

VERIFIED FIXED
83 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- wontfix
firefox83 --- verified

People

(Reporter: csasca, Assigned: whjones526, NeedInfo)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Affected versions

  • Firefox 82.0
  • Firefox 83.0a1

Affected platforms

  • macOS 11
  • Ubuntu 20.04
  • Windows 10

Steps to reproduce

  1. Launch Firefox
  2. Access Preferences and unselect "Enable picture-in-picture video controls" from General section
  3. Launch a youtube video, right click it and select "Picture-in-picture" option
  4. Right click again on the video and unselect "Picture-in-picture" option

Expected result

  • The video reverts to it's original state and position

Actual result

  • The video turns off PIP for a moment then gets back in PIP mode

Regression range

  • I will see for a regression if there is one

Additional notes

  • The issue can be seen in the following attachment

Suggested severity

  • S3
Has Regression Range: --- → no
Has STR: --- → yes

I can reproduce the issue on Nightly83.0a1(20201014214248) Windiows10. However, I cannot on Firefox82.0(20201014125134).
And the problem is reproduced regardless of the option settings.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=9270d433458733f104989082c3be6275a2b06146&tochange=10655b36d226857f983388a1a87a85cdae558689

Regressed by: 1667409
Component: Audio/Video: Playback → Video/Audio Controls
Product: Core → Toolkit

Yes, indeed it is reproducible without disabling the PIP controls, thank you Alice for finding the regression.

Can you look at this, Hunter?

Flags: needinfo?(whjones526)
QA Whiteboard: [qa-triaged]
QA Whiteboard: [qa-triaged] → [qa-regression-triage]
Has Regression Range: no → yes
Assignee: nobody → whjones526
Status: NEW → ASSIGNED
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2fb2e37e5f69
Fix PiP not closing from context-menu r=mconley
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
Flags: qe-verify+

Reproduced the initial issue on Nightly 83.0a1 (buildID: 20201014214248) on Windows 10 x64.
Verified fixed on Windows 10 x64, Ubuntu 20.04 and macOS 11 using Firefox 83 Beta 10 (buildID: 20201108174701).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.