Closed Bug 1671797 Opened 1 year ago Closed 1 year ago

Dark mode CSS is ignored by Firefox 78 on Raspberry Pi

Categories

(Firefox :: Theme, defect)

78 Branch
All
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1529323

People

(Reporter: D-5g6s2dzm5hd, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux aarch64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

I added dark mode CSS to a web page to test whether Mozilla's Dark Theme can correctly display it. It consists of this CSS provided within the STYLE tag.

media (prefers-color-scheme: light) {
body {background:#f0f0f0; color:#000000; }
}
@media (prefers-color-scheme: dark) {
body {background:black; color:#e0e0e0; }
}

Note the platform is Raspberry pi OS 64-bit (fully up to date) running on a Raspberry pi 4b.

Actual results:

After I installed and enabled the Dark Theme, I found that the dark mode CSS had no effect on how the page was displayed when the Dark Theme is enabled.

Expected results:

The colors in the @media (prefers-color-scheme: dark) section are actually supposed to be applied to the content of the web page as it is displayed.
Otherwise, it is not a working dark mode.

My browser is Firefox 78.3esr.

Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core

Thanks for the report!
The dark theme is only a browser theme, it does not control dark/light mode. On Win10, you can configure it in Windows settings.
Workaround on Linux: Open about:config, create a pref called ui.systemUsesDarkTheme, set it to 1 and restart Firefox.

Blocks: dark-mode
Component: Widget: Gtk → Theme
Product: Core → Firefox
Hardware: Unspecified → All
No longer blocks: dark-mode
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1529323
You need to log in before you can comment on or make changes to this bug.