Closed Bug 1671803 Opened 1 year ago Closed 1 year ago

Baidu is not recognized as an "a search engine that searches the entire Web"

Categories

(Firefox :: Address Bar, defect, P2)

Firefox 83
defect
Points:
1

Tracking

()

VERIFIED FIXED
84 Branch
Iteration:
84.1 - Oct 19 - Nov 01
Tracking Status
firefox83 + verified
firefox84 --- verified

People

(Reporter: chnhangmu, Assigned: harry)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

Type 'baidu' in address bar in Nightly (83.0a1 2020/10/17 zh-CN). Maybe you need to install zh-CN language pack.

Actual results:

baidu.com (百度) is the biggest search engine in China mainland.

The action text shown in urlbar results is 'Search Baidu/百度 directly from the address bar' ( like Amazon, searches a specific site)now.

Expected results:

it should look like 'Google' - "Search with Baidu/百度 directly from the address bar"

Maybe search engines (searches the entire Web) in other regions have the same problem.

Blocks: 1647921
Component: Untriaged → Search

We should add the localized name for Baidu to WEB_ENGINE_NAMES.

Blocks: urlbar-searchshortcuts
No longer blocks: 1647921
Severity: -- → S4
Component: Search → Address Bar
Priority: -- → P2
Points: --- → 1
Assignee: nobody → htwyford
Status: UNCONFIRMED → ASSIGNED
Iteration: --- → 84.1 - Oct 19 - Nov 01
Ever confirmed: true
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/73e461c6ee8d
Add localized names for Baidu and Yandex to WEB_ENGINE_NAMES. r=mak

I added a new subtest to browser_tabToSearch called extended_unicode_in_engine. I added it as the last subtest in the file on my machine but by the time it made it to Phabricator, it had inserted itself between two other subtests for some reason. The different sequence of subtests created the failure. I rebased my patch on central and was able to run try run with it as the final test: https://hg.mozilla.org/try/rev/eeeeb043cefd4d824bc252a299e72ce312fc4243.

Flags: needinfo?(htwyford)
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6c5473b9d350
Add localized names for Baidu and Yandex to WEB_ENGINE_NAMES. r=mak
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch

[Tracking Requested - why for this release]: part of the search shortcuts feature planned to be released in 83.

Comment on attachment 9182410 [details]
Bug 1671803 - Add localized names for Baidu and Yandex to WEB_ENGINE_NAMES. r?mak!,standard8

Beta/Release Uplift Approval Request

  • User impact if declined: Users with Baidu and/or Yandex installed will see an incorrect string in the UI. This is part of the work on search shortcuts, a feature launching in 83.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Install Baidu as a search engine. The best way to do this might be to spoof your location to be in China. Alternatively, you could spoof your location to Russia and verify this bug with non-EN Yandex.
  1. Click the Baidu engine one-off button at the bottom of the Urlbar dropdown.
  2. Observe that a blue Baidu "chiclet" is inserted in the Urlbar and the placeholder text reads "Search the Web".

Note - This bug is not fixed if the placeholder text instead reads "Enter search terms".

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Very small change that only affects superficial UI. The patch adds to a lookup that determines what string should be shown in the UI. If this patch doesn't fix the issue, the worst case is that the wrong string is shown in the UI instead.
  • String changes made/needed:
Attachment #9182410 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9182410 [details]
Bug 1671803 - Add localized names for Baidu and Yandex to WEB_ENGINE_NAMES. r?mak!,standard8

Approved for 83 beta 2, thanks.

Attachment #9182410 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

it works, thanks everyone

We tried verifying the issue on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 using Fx84.0a1 and Fx83.0b2 but with no success. After installing baidu as a search engine and clicking it from the URL dropdown, the "Enter search terms" string is still displayed.

Are we missing something?

Flags: needinfo?(htwyford)

Could you please attach a screenshot? I'm interested in what the search mode chiclet says. Also how did you install Baidu?

Flags: needinfo?(htwyford) → needinfo?(cristian.comorasu)
Attached image Chinese simplified.png

Hi Harry,

In windows 10 I downloaded the Chinese simplified version (84.0a1 (2020-10-26)) but I've got a problem. The text is in Chinese so I can't tell if it's the right one or not. Also, since it's greyed out, I can't copy and paste it into a translator. One of my colleagues studies Chinese and she says that the text can be read as Search the web. Also, the Baidu one-off text looks the same as the text of google one-off.

The same thing happened with Yandex on the Russian build. I wasn't able to read it but it looked like the google one-off.

How could we proceed? I think this could be considered fixed.

Regards, Flor.

Thanks for the screenshot, Flor. I checked our Chinese-language strings and it looks like this is correct. The Chinese string for "Search the Web" is here. It's 网上搜索. That matches what's in the screenshot. The Chinese string for "Enter search terms" is 输入搜索词. So I'd say this is fixed!

Flags: needinfo?(cristian.comorasu)

Thanks Harry,

So, I also verified that the beta version 83.0b4 (64 位) is working ok, both for the Russian and the Chinese simplified build. But I did another little experiment and now I have a doubt.

STR:
Download a build that doesn't have Baidu as a search engine from the start
Enable the search bar
Go to Baidu.com
add Baidu as a search engine (from the eye-glass in the search bar)
Focus on the address Bar and choose Baidu's one-off

Actual result:
"Enter search terms".

Shouldn't I also get "Search the Web"?

Flags: needinfo?(htwyford)

Ah, thanks for finding that. Looks like the name of their OpenSearch engine (the one you added from the search bar) is "百度搜索", which translates to "Baidu search". I'll add an exception for that engine as well.

Flags: needinfo?(htwyford)
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/51001c4cc73f
Part 2 - Add localized name for Baidu's OpenSearch engine to WEB_ENGINE_NAMES. r=mak

I assume we'll want to uplift the new patch too.

Flags: needinfo?(htwyford)

Yes, I'm just waiting for the patch to be included in Nightly builds so I can verify it myself and skip additional QA verification. That time is now! I just didn't notice because I was two Nightly versions behind.

Comment on attachment 9183990 [details]
Bug 1671803 - Part 2 - Add localized name for Baidu's OpenSearch engine to WEB_ENGINE_NAMES. r?mak!

Beta/Release Uplift Approval Request

  • User impact if declined: Some people using Baidu will see an incorrect string in the UI. This is part of the work on search shortcuts, a feature launching in 83.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-line change; this is an extra case added to a previous patch that uplifted without problems; there are tests.
  • String changes made/needed:
Flags: needinfo?(htwyford)
Attachment #9183990 - Flags: approval-mozilla-beta?

Comment on attachment 9183990 [details]
Bug 1671803 - Part 2 - Add localized name for Baidu's OpenSearch engine to WEB_ENGINE_NAMES. r?mak!

Approved for 83 beta 6, thanks.

Attachment #9183990 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hi Harry,

I've verified that this has been fixed on FF Nightly 84.0a1 (2020-11-02) but not on Beta 83.0b7 (64-bit) or 83.0b6 (64-bit). Do you have a date for fixing this?

Flags: needinfo?(htwyford)

That's expected since this was approved for Beta but hasn't yet been uplifted. When it is, there will be a comment like comment 11. Maybe this patch fell through the cracks since there's two uplifts in one bug? ni?Julien, is this in the queue to be uplifted?

Flags: needinfo?(htwyford) → needinfo?(jcristau)

No it's not, as it's marked as fixed in 83.

Flags: needinfo?(jcristau)

Thanks. I'm setting 83 as affected so we can get the second part of this patch uplifted.

Hi,

I've verified that this has been fixed on Windows 10 on FF Nightly 84.0a1 (2020-11-04) and on Beta 83.0b8 (64-bit).

Regards, Flor.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.