Closed Bug 1672633 Opened 2 years ago Closed 1 year ago

Firefox stops responding to keyboard shortcuts from time to time under Wayland

Categories

(Core :: Widget: Gtk, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: hsivonen, Unassigned)

References

(Blocks 1 open bug)

Details

Steps to reproduce

  1. Run Firefox for daily use with GDK_BACKEND=wayland on Ubuntu 18.04 in a Gnome Wayland session.
  2. Use keyboard shortcuts for copy, paste, etc.

Actual results

From time to time, Firefox stops responding to keyboard shortcuts like ctrl-c, ctrl-v, ctrl-l, etc. When this happens, alt-f doesn't open the File menu, either. Clicking a text field and typing text works. Shortcuts are restored by alt-tabbing to a different app and back.

Expected result

No loss of shortcuts

Ubuntu 18.0 is very old, don't use it with Wayland. 20.x line should work much better.
Also use MOZ_ENABLE_WAYLAND=1 variable instead of GDK_BACKEND=wayland.

Priority: -- → P3

Not sure if this is in anyway related, but as of a few days I experience a similar issue on macOS (might have started around 87.0a1 (~2021-02-05) (64-bit)). I am considering that it might be related to extensions, but was here to find out if maybe it popped up somewhere else as well.

I think this was already fixed on Mutter side - was caused by two wl_keyboards we have registered.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.