Closed Bug 1673000 Opened 2 years ago Closed 1 year ago

Colour Picker Eyedropper Always Picks Black on Wayland

Categories

(Core :: Widget: Gtk, defect, P2)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
92 Branch
Tracking Status
firefox-esr78 --- wontfix
firefox81 --- wontfix
firefox82 --- wontfix
firefox83 --- wontfix
firefox84 --- wontfix
firefox92 --- fixed

People

(Reporter: matrix.org, Assigned: stransky)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

When using the HTML colour picker component and selecting the eyedropper the result will always be black. This is true weather you click on a firefox window or elsewhere on the desktop.

Blocks: wayland
Component: Graphics → Widget: Gtk
Type: task → defect

Thanks for the report!
Confirmed on Gnome Wayland, Debian Testing, Intel/Mesa. Same behavior with Basic and WebRender on Wayland, EGL/Xwayland, GLX/Xwayland.

STR:
https://developer.mozilla.org/en-US/docs/Web/HTML/Element/input/color
Open the color picker, click on the eyedropper symbol and somewhere on the desktop. The detected color is always black.

Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true

I expect it's because Wayland sandboxes processes and does not allow to access resources of other processes. For instance for desktop sharing PipeWire is used.

It is definitely expected, but it does need to be resolved. Is there an API for colour picker type interactions right now? If not we would probably need to propose something.

(In reply to Kevin Cox [:kevincox] from comment #3)

It is definitely expected, but it does need to be resolved. Is there an API for colour picker type interactions right now? If not we would probably need to propose something.

I'm not aware of any such API.

Jonas, do you know if there's any such API or mechanism on Wayland?
Thanks.

Flags: needinfo?(jadahl)

(In reply to Martin Stránský [:stransky] from comment #5)

Jonas, do you know if there's any such API or mechanism on Wayland?
Thanks.

org.freedesktop.portal.Screenshot.PickColor:

https://github.com/flatpak/xdg-desktop-portal/blob/cb54478e07f1b51537ee75179863c02b5ef97c01/data/org.freedesktop.portal.Screenshot.xml#L84

Flags: needinfo?(jadahl)

Awesome, Thanks!

Priority: -- → P2
Assignee: nobody → stransky
Status: NEW → ASSIGNED
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/1bbd161b6cac
[Linux] Use Gtk color picker, r=jhorak
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
You need to log in before you can comment on or make changes to this bug.