Closed Bug 1674432 Opened 4 months ago Closed 4 months ago

Remove defer usage in devtools/shared/task.js

Categories

(DevTools :: General, task)

task

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1365607

People

(Reporter: hexagonrecursion, Unassigned)

Details

We should use new Promise instead.

I'm claiming the bug now to warn others that I started working on the file. I'll add a patch when I'm done writing it.

Blocks: 1283869

This looks like an poor mans implementation of async-await. Would it be more productive to remove it and replace with real async-await?

Flags: needinfo?(odvarko)
Flags: needinfo?(odvarko)
No longer blocks: 1283869
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1365607
You need to log in before you can comment on or make changes to this bug.