Closed Bug 1674782 Opened 2 years ago Closed 2 years ago

Facebook embedded video is not displayed on chiemgau24.de with ETP - Strict enabled

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Unspecified
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox87 --- affected

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Attached image EtpStrictvsStandard.png

Environment:
Browser / Version: Firefox Nightly 201101 (🦎 84.0a1-20201031094445)
Operating System: Samsung Galaxy S8 (Android 9) - 1440 x 2960 pixels, 18.5:9 ratio (~570 ppi density), Huawei P20 Lite (Android 8.0.0) - 1080 x 2280 pixels, 19:9 ratio (~432 ppi density)

Steps to reproduce:

  1. Navigate to https://www.chiemgau24.de/chiemgau/traunstein/siegsdorf-ort45020/siegsdorf-wirt-vom-papillon-laesst-wut-gegen-corona-politik-im-video-freien-lauf-90083284.html
  2. Scroll down the page (until reaching "... ihr Vollidioten.").
  3. Observe the page.

Expected Behavior:
Facebook embedded video is displayed and can be played.

Actual Behavior:
Facebook embedded video is not displayed.

Notes:

  1. Screenshot attached.
  2. The issue is not reproducible with ETP - Standard enabled.

The breakage is caused by social tracker blocking. The video will be shown if we add connect.facebook.net, www.facebook.com, and *.fbcdn.net into the social tracker skipurl list.

Severity: -- → S3

Have same/similar issue!
Possible dupe: https://bugzilla.mozilla.org/show_bug.cgi?id=1265457

Flags: needinfo?(tihuang)

Thanks for pointing it out.

We would like to keep this bug open instead of closing it as a duplicate so that we can track all sites that are broken by the STP.

Flags: needinfo?(tihuang)
See Also: → 1265457

The URL seems to be outdated, but I found Facebook content that is not displayed with ETP - Strict.
URL: https://www.chiemgau24.de/bayern/corona-pandemie-in-bayern-und-der-region-news-ticker-zum-coronavirus-am-25-februar-2021-90217801.html
https://prnt.sc/106l3f1

Tested with:
Browser / Version: Firefox Nightly 210224 (🦎 87.0a1-20210222084406)
Operating System: Samsung Galaxy S8 (Android 9) - 1440 x 2960 pixels, 18.5:9 ratio (~570 ppi density)

I'm no longer seeing any broken videos on the site, it looks like they are using Glomex player now.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.