Closed Bug 1674802 Opened 1 year ago Closed 1 year ago

Some pages get stuck a little more than half way up using the Home and Page Up keys

Categories

(Core :: Panning and Zooming, defect)

Firefox 82
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- wontfix
firefox83 --- fixed
firefox84 --- fixed

People

(Reporter: scrp445, Assigned: kats)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image IMG_20201102_130603.jpg

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:82.0) Gecko/20100101 Firefox/82.0

Steps to reproduce:

If I search for something in Google, for example "Github" (https://www.google.com/search?client=firefox-b-d&biw=1920&bih=990&ei=JiagX_nZFrqx5OUPr8GrEA&q=github&oq=github&gs_lcp=CgZwc3ktYWIQDFAAWABgxbILaABwAXgAgAEAiAEAkgEAmAEAqgEHZ3dzLXdpeg&sclient=psy-ab&ved=0ahUKEwj5hPzwluTsAhW6GLkGHa_gCgIQ4dUDCAw)
I go to the bottom of the results page. When I want to go back to the beginning with Page Up or Home, the page gets stuck in the middle (or a little above the middle), and unless I use the mouse wheel, the page won't go up. Just when it gets stuck, it blinks a little.
Also, the cursor "believes" that it is at the top of the page. If I select and drag on the word "enciclopedia", instead of selecting it, it makes it "More than".

Actual results:

The page gets stuck in the middle or a little above the middle.

Expected results:

The page should return to the top

I use Manjaro Linux, 2 days since the installation (although in the previous installation of the same Linux was also the same).

I can reproduce the issue on Firefox82.0.2 Windows10 if disable WebRender(i.e.Direct3D 11 (Advanced Layers)) or disable HWA(i.e. Basic).

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Panning and Zooming
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Regressed by: 1661903
See Also: → 1674935
Regressed by: 1662013
No longer regressed by: 1661903

It seems that bug 1657822 fixed this issue and created bug 1674935, so I'll wait until we have a fix for bug 1674935 and then see if anything needs to be done here. I'll park this with me for now.

Assignee: nobody → kats

(In reply to Alice0775 White from comment #2)

I can reproduce the issue on Firefox82.0.2 Windows10 if disable WebRender(i.e.Direct3D 11 (Advanced Layers)) or disable HWA(i.e. Basic).

I confirm, doing this also happens to me in Windows

See Also: → 1675363

I think I'm having the same bug on macOS. (See bug 1675363.)

To those affected by this bug on Firefox 82: can you please download the latest Firefox nightly build and let me know if you're still seeing any issues? Bug 1674935 was fixed yesterday and I expect that everything should work fine in the latest nightly. We can probably uplift that fix to Firefox 83 which will be out in a couple of weeks.

(In reply to Kartikaya Gupta (email:kats@mozilla.staktrace.com) from comment #8)

To those affected by this bug on Firefox 82: can you please download the latest Firefox nightly build and let me know if you're still seeing any issues? Bug 1674935 was fixed yesterday and I expect that everything should work fine in the latest nightly. We can probably uplift that fix to Firefox 83 which will be out in a couple of weeks.

Awesome, I am testing both versions at the same time and did not find the bug. I logged in with the Firefox account on Nightly (with all the extensions), as well as Google and Facebook (where I also had problems) and it works fine. Thank you!

Thanks! I'll mark this as fixed by bug 1657822.

Status: NEW → RESOLVED
Closed: 1 year ago
Depends on: 1657822
Resolution: --- → FIXED
Duplicate of this bug: 1675363
You need to log in before you can comment on or make changes to this bug.