Closed Bug 1675050 Opened 11 months ago Closed 11 months ago

"Sponsored Top Sites" checkbox shouldn't need a restart to show up after setting browser.topsites.useRemoteSetting=true

Categories

(Firefox :: Top Sites, defect, P1)

Firefox 83
defect
Points:
1

Tracking

()

VERIFIED FIXED
84 Branch
Iteration:
84.2 - Nov 2 - Nov 15
Tracking Status
firefox82 --- unaffected
firefox83 --- verified
firefox84 --- verified

People

(Reporter: dao, Assigned: dao)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

No description provided.
Iteration: --- → 84.2 - Nov 2 - Nov 15
Points: --- → 1
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/81e8f84c8ec0
"Sponsored Top Sites" checkbox shouldn't need a restart to show up after enabling the remote settings backend. r=mikedeboer
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dbc6afc7db11
"Sponsored Top Sites" checkbox shouldn't need a restart to show up after enabling the remote settings backend. r=mikedeboer
Flags: needinfo?(dao+bmo)
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
Summary: "Sponsored Top Sites" checkbox shouldn't need a restart to show up after enabling the remote settings backend → "Sponsored Top Sites" checkbox shouldn't need a restart to show up after setting browser.topsites.useRemoteSetting=true

Comment on attachment 9185522 [details]
Bug 1675050 - "Sponsored Top Sites" checkbox shouldn't need a restart to show up after enabling the remote settings backend. r=mikedeboer

Beta/Release Uplift Approval Request

  • User impact if declined: As part of an upcoming experiment in Firefox 83 that will enable browser.topsites.useRemoteSetting, it's expected that users can disable sponsored about:newtab tiles by unchecking the "Sponsored Top Sites" checkbox in about:preferences#home.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: set browser.topsites.useRemoteSetting to true in about:config, then open about:preferences#home and find the "Sponsonred Top Sites" checkbox
  • List of other uplifts needed: -
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): trivial fix
  • String changes made/needed: -
Attachment #9185522 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9185522 [details]
Bug 1675050 - "Sponsored Top Sites" checkbox shouldn't need a restart to show up after enabling the remote settings backend. r=mikedeboer

Uplift approved for our last beta, thanks.

Attachment #9185522 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I'm hitting conflicts in browser/components/newtab/karma.mc.config.js when applying this on beta

Flags: needinfo?(dao+bmo)
Attached patch patch for upliftSplinter Review
Flags: needinfo?(dao+bmo)
QA Whiteboard: [qa-triaged]

Verified using Firefox 83 beta 10 and latest Nightly 84.0a1 2020-11-09 under Win 10 x64 and Ubuntu 18.04 x64 that the browser doesn't need a restart for "Sponsored Top Sites" checkbox to be shown in about:preferences#home when switching browser.topsites.useRemoteSetting to True.

However, if Preferences page is already opened, it needs to be refreshed in order for the checkbox to be displayed. :dao, is this intended or should I file a follow-up? I only compared it with browser.newtabpage.activity-stream.showSearch checkbox that it's instantly checked/unchecked on about:preferences page. Thank you!

Flags: needinfo?(dao+bmo)

(In reply to Petruta Horea [:phorea] from comment #11)

However, if Preferences page is already opened, it needs to be refreshed in order for the checkbox to be displayed. :dao, is this intended or should I file a follow-up? I only compared it with browser.newtabpage.activity-stream.showSearch checkbox that it's instantly checked/unchecked on about:preferences page. Thank you!

This is fine as is.

Flags: needinfo?(dao+bmo)

Thanks!
Marking as verified based on above comments.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.