Closed Bug 1675301 Opened 5 months ago Closed 5 months ago

Firefox very slow on Reddit with VoiceOver and Braille enabled

Categories

(Core :: Disability Access APIs, defect, P1)

Firefox 84
Desktop
macOS
defect

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox84 --- wontfix
firefox85 --- fixed

People

(Reporter: MarcoZ, Assigned: eeejay)

Details

(Keywords: perf, Whiteboard: [Mac2020_2])

Attachments

(1 file)

Steps:

  1. Open Reddit and log in.
  2. Open an article, I was using this.
  3. Navigate using VO. Observations:
    • Navigating by Heading is fast.
    • Navigating by VoiceOver+RightArrow or VoiceOver+LeftArrow sequentially is very slow. It does work, but takes several seconds to go from item to item.
    • Expected: Should be fast.

I can't reproduce this. Can you say on which two nodes, or sequence of nodes, you see lag?

Flags: needinfo?(mzehe)

Ah! I think I found this issue. Assuming you have a braille device connected. There are certainly slowdowns when I enable braille.

Flags: needinfo?(mzehe)

Yes, I do have a Braille display connected. Sorry, this is so second nature for me (and many other Europeans) that I sometimes forget that this could be a deciding factor.

Summary: Firefox very slow on Reddit with VoiceOver → Firefox very slow on Reddit with VoiceOver and Braille enabled

I worry that there is some tree corruption happening here. So I want to make this a P1 and investigate further.

Priority: P2 → P1

No objections from this end. I can still reproduce this reliably. I also see a much less drastic, but still profound, difference when navigating through a Gmail conversation with and without Braille. Without Braille, it's fast, with, it's laggy, but not as bad as this Reddit, but probably a similar cause.

Please let me know if I can be of any more help, since I always have a Braille display connected. I am also set up to build.

It seems that VO mistakenly thinks the web area is a descendant of itself. This causes all kinds of cyclical parent child relationships that makes VO over-query us.

This patch remedies that by not returning the web area when do an immediate child search starting from the root group - in any direction.

Assignee: nobody → eitan
Status: NEW → ASSIGNED
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/589cd0252a11
Don't return web area as result when searching backwards from root group. r=morgan
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

The patch landed in nightly and beta is affected.
:eeejay, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(eitan)

Not worth fixing in beta.

Flags: needinfo?(eitan)
You need to log in before you can comment on or make changes to this bug.