RFE: move field init msg above form as bug 16719 workaround

VERIFIED WONTFIX

Status

()

P3
enhancement
VERIFIED WONTFIX
20 years ago
6 years ago

People

(Reporter: sidr, Assigned: justdave)

Tracking

Details

(URL)

(Reporter)

Description

20 years ago
As described in Bug 16719, under Additional Comments, the Component,
Platform, and OS for bugs entered through enter_bug.cgi with M10 are coming
up with some wildly unuseful values for some fields:
Component:ActiveX Wrapper, Platform:Other, OS:other

This is happening because of Bug 15841, verified 1999-10-18, but affecting M10.

Suggested temporary and partial workaround:
Move the message "Some fields initialized from your user-agent, Mozilla/4.7
[en] (WinNT; I). If you think it got it wrong, please tell terry@mozilla.org
what it should have been." from below the FORM on enter_bug.cgi to above
the form, and change it to something like:

"Platform and OS should be initialized from your user-agent, XYZZY.
Please check to make sure the Platform and OS are correct, and set
the Component to whatever makes sense (Click the work Component
for help)."

This should not take too much work, and may somewhat reduce the
number of unuseable reports from first-time reporters.

Speculation:
The OS and Platform SELECTS are having the "other" OPTION selected as a side
effect of having, in effect, two OPTIONS SELECTED in a SELECT without the
MULTIPLE attribute set, an error condition for which there may be no
handler. The HTML 4 spec unhelpfully leaves it up to the implementer how
to handle this: http://www.w3.org/TR/REC-html40/interact/forms.html#h-17.6.1

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WONTFIX

Comment 1

20 years ago
No, I'm not going to spend time tweaking pages to work around transient bugs in
Mozilla.
per Terry, auto-verifying any resolved bug that hasn't been touched since before 
2.10 was released.
Status: RESOLVED → VERIFIED
moving all closed Bugzilla bugs to the new Bugzilla product.
This batch is DUPLICATE/INVALID/WORKSFORME/WONTFIX
reassigning to default owner and QA in case of the bug being reopened.
Clearing milestones, since we really shouldn't have them on these types of
resolutions.  Sorry for the spam everyone...
Assignee: terry → justdave
Status: VERIFIED → NEW
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Version: other → unspecified
damn, bit by bug 30731. sorry for the respam...  one more coming to complete the
status fix
Status: NEW → RESOLVED
Last Resolved: 20 years ago18 years ago
completing status fix...
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.