Closed Bug 1675503 Opened 1 year ago Closed 1 year ago

Measure page performance over HTTP3

Categories

(Core :: Networking: HTTP, task, P2)

task

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox85 --- fixed

People

(Reporter: dragana, Assigned: dragana)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

Attachments

(2 files)

The following 3 existing probes are relevant:

  • TIME_TO_FIRST_CONTENTFUL_PAINT_MS
  • TIME_TO_NON_BLANK_PAINT_MS
  • FX_PAGE_LOAD_MS_2.

Probes needed:

  • TIME_TO_FIRST_CONTENTFUL_PAINT_MS_HTTP3 - The same as TIME_TO_FIRST_CONTENTFUL_PAINT_MS but only records pages that have used HTTP3 to fetch the main document
  • TIME_TO_FIRST_CONTENTFUL_PAINT_MS_HTTP2_SUP_HTTP3 - The same as TIME_TO_FIRST_CONTENTFUL_PAINT_MS but only records pages that have not used HTTP3 to fetch the main document but the server the main document has been fetched from supports HTTP3
  • TIME_TO_NON_BLANK_PAINT_MS_HTTP3/HTTP2_SUP_HTTP3 - This is similar as above to separate probe TIME_TO_NON_BLANK_PAINT_MS into: 1) pages that have used HTTP3 and 2) pages that have not used HTTP3 but support HTTP3
  • FX_PAGE_LOAD_MS_2_HTTP3/HTTP2_SUP_HTTP3 - This is similar as above to separate probe FX_PAGE_LOAD_MS_2 into: 1) pages that have used HTTP3 and 2) pages that have not used HTTP3 but support HTTP3
Summary: Measure the the performance over HTTP3 → Measure page performance over HTTP3

This will be collected for sites that have used HTTP3 and for sites that support HTTP3 but HTTP3 has not been used.

Attached file request1675503.md
Attachment #9187288 - Flags: data-review?(chutten)
Assignee: nobody → dd.mozilla
Status: NEW → ASSIGNED

Comment on attachment 9187288 [details]
request1675503.md

DATA COLLECTION REVIEW RESPONSE:

Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes.

Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, :dragana is responsible.

Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 1, Technical.

Is the data collection request for default-on or default-off?

Default on for all channels.

Does the instrumentation include the addition of any new identifiers?

No.

Is the data collection covered by the existing Firefox privacy notice?

Yes.

Does there need to be a check-in in the future to determine whether to renew the data?

No. This collection is permanent.


Result: datareview+

Attachment #9187288 - Flags: data-review?(chutten) → data-review+
Duplicate of this bug: 1657172
Pushed by ddamjanovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0f9cc38b1f60
Add telemetry for the page load time and the time to first paint for sites that support HTTP3 r=smaug,bas
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
You need to log in before you can comment on or make changes to this bug.