Closed Bug 1675643 Opened 5 months ago Closed 5 months ago

Cookie AutoDelete localStorage cleanup throws when dom.storage.next_gen is false

Categories

(WebExtensions :: General, defect)

Firefox 84
defect

Tracking

(firefox-esr78 unaffected, firefox82 unaffected, firefox83 unaffected, firefox84 fixed)

RESOLVED FIXED
84 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- unaffected
firefox83 --- unaffected
firefox84 --- fixed

People

(Reporter: gwarser, Assigned: evilpie)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:84.0) Gecko/20100101 Firefox/84.0

Steps to reproduce:

Actual results:

"Error! An unexpected error occurred" notification is displayed. Debugger shows that something throws in code, but is catched.

mozregression points to https://bugzilla.mozilla.org/show_bug.cgi?id=1670811

Expected results:

Storage cleaned successfully, no error notifications.

Component: Untriaged → General
Product: Firefox → WebExtensions
Summary: Cookie AutoDelete localStorage cleanup → Cookie AutoDelete localStorage cleanup throws when dom.storage.next_gen is false
Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1670811

26:34.74 INFO: Running autoland build built on 2020-11-03 19:45:20, revision 12e386f1
26:47.08 INFO: Launching /tmp/tmp7ck8w5a5/firefox/firefox
26:47.08 INFO: Application command: /tmp/tmp7ck8w5a5/firefox/firefox --allow-downgrade --allow-downgrade -profile /home/rdk/.mozilla/firefox/4gucti37.dev-edition-default
26:47.09 INFO: application_buildid: 20201103183559
26:47.09 INFO: application_changeset: 12e386f1f5413415698dddd8cce87b00086b1279
26:47.09 INFO: application_name: Firefox
26:47.09 INFO: application_repository: https://hg.mozilla.org/integration/autoland
26:47.09 INFO: application_version: 84.0a1
Was this integration build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', 'back' or 'exit' and press Enter): bad
27:34.40 INFO: Narrowed integration regression window from [0db0e6a3, a0678795] (3 builds) to [0db0e6a3, 12e386f1] (2 builds) (~1 steps left)
27:34.40 INFO: No more integration revisions, bisection finished.
27:34.40 INFO: Last good revision: 0db0e6a3f8f01d3060adeaaa0aa599b169811f24
27:34.40 INFO: First bad revision: 12e386f1f5413415698dddd8cce87b00086b1279
27:34.40 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0db0e6a3f8f01d3060adeaaa0aa599b169811f24&tochange=12e386f1f5413415698dddd8cce87b00086b1279

Assignee: nobody → evilpies
Pushed by evilpies@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bdb7fef18864
Fix browsingData.removeLocalStorage when next-gen storage is disabled. r=rpl

Thanks for your report. The central-as-beta would maybe have caught this as well. I am not sure if that counts as early beta. Writing a test for this directly turns out to me a bit difficult because we need to set dom.storage.next_gen during startup.

The central-as-late-beta simulation caught this today, but gwarser was faster. Late beta sims have been reduced to two runs per week.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
You need to log in before you can comment on or make changes to this bug.