Closed Bug 1675857 Opened 4 months ago Closed 3 months ago

[dialog element] <dialog> positioning should be describable in CSS

Categories

(Core :: Layout: Positioned, defect)

defect

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox85 --- fixed

People

(Reporter: mozilla-apprentice, Assigned: sefeng)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file)

A resolution was made for csswg-drafts/#4645.

[dialog element] <dialog> positioning should be describable in CSS

  • RESOLVED: Add a hidden pseudo-class for this purpose, in order to solve styling issue while leavine open the possibility of HTML improving its API

Discussion.

Sean do you plan to work on this?

Flags: needinfo?(sefeng)

Yeah, I plan to get this one next week :).

Assignee: nobody → sefeng
Status: NEW → ASSIGNED
Pushed by sefeng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c3bb21d00d4
Update <dialog> internal styles for spec alignment r=emilio
Pushed by sefeng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5ee2649eac61
Update <dialog> internal styles for spec alignment r=emilio
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
Flags: needinfo?(sefeng)

Ah, on second look, this looks like an internal styles-only thing, so it probably doesn't need any documentation on MDN.

Keywords: dev-doc-needed
Regressions: 1669734
You need to log in before you can comment on or make changes to this bug.