Last Comment Bug 167601 - [object] Support <param name="PLUGINURL" ...>
: [object] Support <param name="PLUGINURL" ...>
Status: RESOLVED FIXED
[PL2:NA]
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: mozilla1.2beta
Assigned To: Peter Lubczynski
: shrirang khanzode
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 15:31 PDT by rubydoo123
Modified: 2002-09-25 17:27 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v.1 (1.91 KB, patch)
2002-09-14 17:25 PDT, Peter Lubczynski
peterlubczynski-bugs: review+
jst: superreview+
Details | Diff | Splinter Review

Description rubydoo123 2002-09-09 15:31:21 PDT
Submitting bug to track the coding to support pluginspage in param element.

The param element coding:
<param name="pluginspage" value="path to xpi file">

The default plug-in functionality should be the same as with the embed element
and the codebase attribute hack. This is to provide a mechanism to phase out the
codebade attribute hack.
Comment 1 rubydoo123 2002-09-09 16:32:50 PDT
Arun corrected my mistake in requesting pluginspage instead of pluginsurl. So,
the request should be to use pluginsurl. I have updated the Summary to reflect
that change.

Arun also pointed me to an historical reference of the use:
http://developer.netscape.com/docs/manuals/htmlguid/tags14.htm#1684921

Thanks Arun!
Comment 2 Peter Lubczynski 2002-09-14 17:25:27 PDT
Created attachment 99228 [details] [diff] [review]
patch v.1

This patch will look for PLUGINURL (singular) in the PARAM tags of OBJECT tags
instead of CODEBASE. The default plugins are already setup to look for this.
Comment 3 Peter Lubczynski 2002-09-14 17:28:56 PDT
According to the spec here:
http://developer.netscape.com/docs/manuals/htmlguid/tags14.htm#1684921

The name value should be singluar ___PLUGINURL__

----

Anthony, can I get a review?
Comment 4 anthonyd 2002-09-16 15:51:56 PDT
r=anthonyd, looks good.
Comment 5 Peter K. Sheerin 2002-09-18 10:58:05 PDT
Should both PLUGINSPAGE and PLUGINURL be supported, as the reference from Arun
about Netscape 4.x documents? That would provide the advantage of allowing an
unambiguous method of specifying whether the URI points to an XPI package or a
human-readable download instruction page.

PLUGINURL could also be used by other browsers that don't support any automatic
download/installation, and by Mozilla for those cases when the XPI installation
fails (say, because the XPI doesn't contain a plugin compatible with the user's
platform).

(From http://developer.netscape.com/docs/manuals/htmlguid/tags14.htm#1684921 )
----
PLUGINSPAGE="instrURL"
specifies the URL that contains the instructions for installing the plug-in if
it is not already installed.

PLUGINURL="pluginURL"
is the URL of a Java Archive (JAR) file, which is a compressed collection of
files that can be signed.
----
Comment 6 rubydoo123 2002-09-19 13:32:51 PDT
Peter S: see bug 169743 (just opened for pluginspage support
Comment 7 Johnny Stenback (:jst, jst@mozilla.com) 2002-09-23 18:22:08 PDT
Comment on attachment 99228 [details] [diff] [review]
patch v.1

sr=jst
Comment 8 Peter Lubczynski 2002-09-24 13:18:28 PDT
Comment on attachment 99228 [details] [diff] [review]
patch v.1

(from comments)
Comment 9 Peter K. Sheerin 2002-09-24 16:20:55 PDT
The relevant comment in the patch still refers to pluginspage:

+    // if we didn't find a PluginsPage param on the object tag, 
+    // there's nothing more to do here
+    if(nsPluginTagType_Object == tagType && !bHasPluginURL)
       return rv;

That should probably be changed to PluginURL to avoid confusing things...
Comment 10 Peter Lubczynski 2002-09-25 17:27:13 PDT
comment fixed and patch checked into the trunk, marking FIXED

Note You need to log in before you can comment on or make changes to this bug.