Closed Bug 1676199 Opened 3 months ago Closed 2 months ago

Print preview for pdfs refreshes when toggling options that should not have a direct effect inside the preview

Categories

(Toolkit :: Printing, defect, P2)

defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- wontfix
firefox84 --- wontfix
firefox85 --- verified

People

(Reporter: Anca, Assigned: emalysz)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [print2020_v85] [old-ui-])

Attachments

(2 files)

Attached image screencast issue.gif

Affected versions

  • 84.0a1
  • 85.0b10

Affected platforms

  • Windows 10
  • Windows 7
  • Ubuntu 18.04

Steps to reproduce

  1. Launch Firefox
  2. Make sure print.tab_modal.enabled is set on true
  3. Hit CTRL + P on any pdf page (eg. http://www.dbsparks.com/research/html/SNRN02.pdf)
  4. Extent More setting
  5. Check the Print on both sides option

Expected result

  • The checkbox is checked, no refresh in preview

Actual result

  • The checkbox is checked, the print preview refreshes

Regression range

Additional notes

  • The Copies section has a refresh effect only if previously the destination was changed
  • See also - 1663019 - the behavior of Print headers and footers and Print backgrounds, which is also problematic as it is right now, but not actually directly related with the expected result targeted in this issue
  • Only pdf seams to be affected

Suggested severity

  • S4, since no functionality is affected
Has Regression Range: --- → yes
Has STR: --- → yes
Severity: -- → S4
Priority: -- → P2
Whiteboard: [print2020_v84] [old-ui-] → [print2020_v85] [old-ui-]
Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7ffa5edf05ad
do not refresh preview for changes to copies or duplex printing r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

Verified fixed with Fx 85.0a1 (2020-12-11) on Windows 10, Ubuntu 18.04 and macOS 10.15.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.