Closed Bug 1676434 Opened 1 year ago Closed 1 year ago

Remove obsolete -moz-mac-yosemite-theme media query and add -moz-mac-big-sur-theme

Categories

(Core :: CSS Parsing and Computation, task)

task

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox84 --- fixed
firefox85 --- fixed

People

(Reporter: ntim, Assigned: mstange)

References

Details

Attachments

(1 file)

This is now always true, and all -moz-mac-yosemite-theme usages have been removed in bug 1673321.

I'm going to combine this with adding support for a new media query for macOS Big Sur. That way, the patch can just be a rename.

Assignee: nobody → mstange.moz
Status: NEW → ASSIGNED
Summary: Remove obsolete -moz-mac-yosemite-theme media query → Remove obsolete -moz-mac-yosemite-theme media query and add -moz-mac-big-sur-theme
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/8b98ebe79283
Replace obsolete -moz-mac-yosemite-theme media query with a new -moz-mac-big-sur-theme media query. r=emilio
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
See Also: → 1677949
Blocks: 1672091

Comment on attachment 9187887 [details]
Bug 1676434 - Replace obsolete -moz-mac-yosemite-theme media query with a new -moz-mac-big-sur-theme media query. r=#style

Beta/Release Uplift Approval Request

  • User impact if declined: needed for bug 1672091
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): it's a simple rename of something that's unused since 84
  • String changes made/needed:
Attachment #9187887 - Flags: approval-mozilla-beta?

Comment on attachment 9187887 [details]
Bug 1676434 - Replace obsolete -moz-mac-yosemite-theme media query with a new -moz-mac-big-sur-theme media query. r=#style

approved for 84.0b5

Attachment #9187887 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.