Closed Bug 1676839 Opened 10 months ago Closed 9 months ago

[macOS 11] PNG transparency example will not print successfully

Categories

(Core :: Printing: Output, defect, P1)

Desktop
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox84 --- affected

People

(Reporter: csasca, Unassigned)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [print2020_v85] [old-ui?])

Attachments

(2 files)

Affected versions

  • Firefox 84.0a1

Affected platforms

  • macOS 11

Steps to reproduce

  1. Launch Firefox
  2. Access this test page
  3. Print the page

Expected result

  • The page is printed successfully with color

Actual result

  • Around 10% of the page is printed then the printer stalls for 5 minutes then cancels the printing

Regression range

  • I will see for a regression if there is one

Additional notes

  • The issues can be seen in the attachments.
  • The printing is done via Wireless
  • Chrome prints the page ok, but it seems different than the preview from Firefox
  • Firefox will print the PNG example, but only if black and white is selected
  • Other examples as SVG will print ok
  • This may be some driver incompatibility issue
  • Ubuntu 20.04 is not affected and will print the page ok

Suggested severity

  • S2
Has Regression Range: --- → no
Has STR: --- → yes
Attached image chrome color print.png

And here's chrome's print part

Blocks: 1648487

It does seem like this is driver-specific, so I will set as S3 for now. Unable to reproduce on macOS 10.15.7 with my HP printer locally.

Does this reproduce with the old print UI?

Severity: -- → S3
Flags: needinfo?(catalin.sasca)
Priority: -- → P1

Hey Sean, sorry for the late response, tried now reproducing the issue, but it seems that it has somehow been fixed (maybe some updates to mac11) or from Firefox. Tried on 84.0b4 and 85.0a1 (23-11-2020) and it printed the file wirelessly as expected. I think we are safe for now here.

Flags: needinfo?(catalin.sasca)
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.