Crashed trying to open url

RESOLVED DUPLICATE of bug 154699

Status

Camino Graveyard
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 154699
15 years ago
15 years ago

People

(Reporter: Barry Early, Assigned: Brian Nesse (gone))

Tracking

({crash})

Details

(URL)

(Reporter)

Description

15 years ago
Date/Time:  2002-09-10 11:06:35 -0400
OS Version: 10.2 (Build 6C115)
Host:       c-24-98-248-11.atl.client2.attbi.com

Command:    Navigator
PID:        639

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000034

Thread 0:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x92868468 in JVM_DoPrivileged
 #5   0x928e2df4 in JVM_GC
 #6   0x928e787c in JVM_TotalMemory
 #7   0x92867a08 in JVM_DoPrivileged
 #8   0x92857bc8 in JVM_GetMethodIxLocalsCount
 #9   0x928a21f8 in JVM_Close
 #10  0x940b1780 in LockAcquire
 #11  0x8cfd303c in _Z17InitJavaEmbeddingRP7JNIEnv_
 #12  0x8cfd57d4 in CreateJavaApplet
 #13  0x02322980 in loadApplet__10MRJContext
 #14  0x02323668 in setWindow__10MRJContextP14nsPluginWindow
 #15  0x02325904 in SetWindow__17MRJPluginInstanceP14nsPluginWindow
 #16  0x00394b60 in
InstantiateEmbededPlugin__16nsPluginHostImplPCcP6nsIURIP22nsIPluginInstanceOwner
 #17  0x0067551c in
InstantiatePlugin__13nsObjectFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateP13nsIPluginHostPCcP6nsIURI
 #18  0x006746b0 in
Reflow__13nsObjectFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #19  0x0078ddc0 in ReflowFrame__12nsLineLayoutP8nsIFrameRUiP19nsHTMLReflowMetricsRi
 #20  0x00600420 in
ReflowInlineFrame__12nsBlockFrameR18nsBlockReflowStateR12nsLineLayoutG19nsLineList_iteratorP8nsIFramePUc
 #21  0x006001d4 in
DoReflowInlineFrames__12nsBlockFrameR18nsBlockReflowStateR12nsLineLayoutG19nsLineList_iteratorPiPUcii
 #22  0x0060001c in
DoReflowInlineFramesAuto__12nsBlockFrameR18nsBlockReflowStateG19nsLineList_iteratorPiPUcii
 #23  0x005ffea0 in
ReflowInlineFrames__12nsBlockFrameR18nsBlockReflowStateG19nsLineList_iteratorPiii
 #24  0x005fe8d0 in
ReflowLine__12nsBlockFrameR18nsBlockReflowStateG19nsLineList_iteratorPii
 #25  0x005fe064 in ReflowDirtyLines__12nsBlockFrameR18nsBlockReflowState
 #26  0x005fcac0 in
Reflow__12nsBlockFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #27  0x006ccf7c in
ReflowChild__16nsContainerFrameP8nsIFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateiiUiRUi
 #28  0x006964c8 in
Reflow__16nsTableCellFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #29  0x006ccf7c in
ReflowChild__16nsContainerFrameP8nsIFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateiiUiRUi
 #30  0x006aaa9c in
ReflowChildren__15nsTableRowFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateR12nsTableFrameRUii
 #31  0x006ab8f4 in
Reflow__15nsTableRowFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #32  0x006ccf7c in
ReflowChild__16nsContainerFrameP8nsIFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateiiUiRUi
 #33  0x005f5338 in
ReflowChildren__20nsTableRowGroupFrameP14nsIPresContextR19nsHTMLReflowMetricsR21nsRowGroupReflowStateRUiP15nsTableRowFrameiPPB4Pi
 #34  0x005f6e50 in
Reflow__20nsTableRowGroupFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #35  0x006ccf7c in
ReflowChild__16nsContainerFrameP8nsIFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateiiUiRUi
 #36  0x0069f0e4 in
ReflowChildren__12nsTableFrameP14nsIPresContextR18nsTableReflowStateiiRUiRP8nsIFramePi
 #37  0x0069be9c in
Reflow__12nsTableFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #38  0x006ccf7c in
ReflowChild__16nsContainerFrameP8nsIFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateiiUiRUi
 #39  0x006929b0 in
OuterReflowChild__17nsTableOuterFrameP14nsIPresContextP8nsIFrameRC17nsHTMLReflowStateR19nsHTMLReflowMetricsPiR6nsSizeR8nsMarginn214nsReflowReasonRUi
 #40  0x0069423c in
Reflow__17nsTableOuterFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #41  0x00795c0c in
DoReflowBlock__20nsBlockReflowContextR17nsHTMLReflowState14nsReflowReasonP8nsIFrameRC6nsRectiR18nsCollapsingMarginiR8nsMarginRUi
 #42  0x007956bc in
ReflowBlock__20nsBlockReflowContextP8nsIFrameRC6nsRectiR18nsCollapsingMarginiR8nsMarginRUi
 #43  0x005ff924 in
ReflowBlockFrame__12nsBlockFrameR18nsBlockReflowStateG19nsLineList_iteratorPi
 #44  0x005fe520 in
ReflowLine__12nsBlockFrameR18nsBlockReflowStateG19nsLineList_iteratorPii
 #45  0x005fe064 in ReflowDirtyLines__12nsBlockFrameR18nsBlockReflowState
 #46  0x005fcac0 in
Reflow__12nsBlockFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #47  0x00795c0c in
DoReflowBlock__20nsBlockReflowContextR17nsHTMLReflowState14nsReflowReasonP8nsIFrameRC6nsRectiR18nsCollapsingMarginiR8nsMarginRUi
 #48  0x007956bc in
ReflowBlock__20nsBlockReflowContextP8nsIFrameRC6nsRectiR18nsCollapsingMarginiR8nsMarginRUi
 #49  0x005ff924 in
ReflowBlockFrame__12nsBlockFrameR18nsBlockReflowStateG19nsLineList_iteratorPi
 #50  0x005fe520 in
ReflowLine__12nsBlockFrameR18nsBlockReflowStateG19nsLineList_iteratorPii
 #51  0x005fe064 in ReflowDirtyLines__12nsBlockFrameR18nsBlockReflowState
 #52  0x005fcac0 in
Reflow__12nsBlockFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #53  0x00795c0c in
DoReflowBlock__20nsBlockReflowContextR17nsHTMLReflowState14nsReflowReasonP8nsIFrameRC6nsRectiR18nsCollapsingMarginiR8nsMarginRUi
 #54  0x007956bc in
ReflowBlock__20nsBlockReflowContextP8nsIFrameRC6nsRectiR18nsCollapsingMarginiR8nsMarginRUi
 #55  0x005ff924 in
ReflowBlockFrame__12nsBlockFrameR18nsBlockReflowStateG19nsLineList_iteratorPi
 #56  0x005fe520 in
ReflowLine__12nsBlockFrameR18nsBlockReflowStateG19nsLineList_iteratorPii
 #57  0x005fe064 in ReflowDirtyLines__12nsBlockFrameR18nsBlockReflowState
 #58  0x005fcac0 in
Reflow__12nsBlockFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #59  0x006ccf7c in
ReflowChild__16nsContainerFrameP8nsIFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateiiUiRUi
 #60  0x0060af68 in
Reflow__11CanvasFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #61  0x007bd8e8 in
Reflow__19nsBoxToBlockAdaptorR16nsBoxLayoutStateP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUiin4
 #62  0x007bd320 in DoLayout__19nsBoxToBlockAdaptorR16nsBoxLayoutState
 #63  0x006d42f8 in Layout__5nsBoxR16nsBoxLayoutState
 #64  0x005f9b40 in DoLayout__16nsScrollBoxFrameR16nsBoxLayoutState
 #65  0x006d42f8 in Layout__5nsBoxR16nsBoxLayoutState
 #66  0x006d7434 in
LayoutChildAt__14nsContainerBoxR16nsBoxLayoutStateP6nsIBoxRC6nsRect
 #67  0x006317d8 in Layout__21nsGfxScrollFrameInnerR16nsBoxLayoutState
 #68  0x00631498 in DoLayout__16nsGfxScrollFrameR16nsBoxLayoutState
 #69  0x006d42f8 in Layout__5nsBoxR16nsBoxLayoutState
 #70  0x00605de8 in
Reflow__10nsBoxFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #71  0x00630a14 in
Reflow__16nsGfxScrollFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #72  0x006ccf7c in
ReflowChild__16nsContainerFrameP8nsIFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateiiUiRUi
 #73  0x006bd1f4 in
Reflow__13ViewportFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi
 #74  0x00345394 in
Dispatch__17IncrementalReflowP14nsIPresContextR19nsHTMLReflowMetricsRC6nsSizeR19nsIRenderingContext
 #75  0x00351da4 in ProcessReflowCommands__9PresShelli
 #76  0x003518d4 in HandlePLEvent__FP11ReflowEvent
 #77  0x05056e80 in PL_HandleEvent
 #78  0x05056d68 in PL_ProcessPendingEvents
 #79  0x05057d30 in ProcessPendingEvents__16nsEventQueueImpl
 #80  0x00433b74 in -[EventQueueHandler eventTimer:]
 #81  0x907e521c in __NSFireTimer
 #82  0x90163884 in __CFRunLoopDoTimer
 #83  0x901493e8 in __CFRunLoopRun
 #84  0x90181578 in CFRunLoopRunSpecific
 #85  0x92ba34cc in RunCurrentEventLoopInMode
 #86  0x92bb32f4 in ReceiveNextEventCommon
 #87  0x92bda280 in BlockUntilNextEventMatchingListInMode
 #88  0x93082184 in _DPSNextEvent
 #89  0x930ccf84 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
 #90  0x930ca500 in -[NSApplication run]
 #91  0x930d2598 in NSApplicationMain
 #92  0x00005024 in main
 #93  0x00004ed4 in _start
 #94  0x00004d04 in start

Thread 1:
 #0   0x90025e8c in select
 #1   0x0101d804 in poll
 #2   0x01019ecc in _pr_poll_with_poll
 #3   0x0016a68c in Run__24nsSocketTransportService
 #4   0x050598f0 in Main__8nsThreadPv
 #5   0x0101b388 in _pt_root
 #6   0x90021428 in _pthread_body

Thread 2:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x01016474 in PR_WaitCondVar
 #3   0x0014b2cc in DequeuePendingQ__12nsDNSService
 #4   0x0014acd4 in Run__12nsDNSService
 #5   0x050598f0 in Main__8nsThreadPv
 #6   0x0101b388 in _pt_root
 #7   0x90021428 in _pthread_body

Thread 3:
 #0   0x90042d68 in semaphore_timedwait_signal_trap
 #1   0x9003ef94 in _pthread_cond_wait
 #2   0x01016210 in pt_TimedWait
 #3   0x01016488 in PR_WaitCondVar
 #4   0x0505d38c in Run__11TimerThread
 #5   0x050598f0 in Main__8nsThreadPv
 #6   0x0101b388 in _pt_root
 #7   0x90021428 in _pthread_body

Thread 4:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x01016474 in PR_WaitCondVar
 #3   0x0505aa2c in GetRequest__12nsThreadPoolP9nsIThread
 #4   0x0505b3a0 in Run__20nsThreadPoolRunnable
 #5   0x050598f0 in Main__8nsThreadPv
 #6   0x0101b388 in _pt_root
 #7   0x90021428 in _pthread_body

Thread 5:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x90824180 in -[NSConditionLock lockWhenCondition:]
 #3   0x933515f4 in -[NSUIHeartBeat _heartBeatThread:]
 #4   0x9081cd38 in forkThreadForFunction
 #5   0x90021428 in _pthread_body

Thread 6:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x928ec28c in JNI_CreateJavaVM_Impl
 #3   0x928ec224 in JNI_CreateJavaVM_Impl
 #4   0x928a51fc in JVM_GetClassMethodsCount
 #5   0x90021428 in _pthread_body

Thread 7 Crashed:
 #0   0x929ba640 in eh_rest_world_r10
 #1   0x928322b0 in _mh_dylib_header
 #2   0x92892920 in JVM_IsSameClassPackage
 #3   0x928917f4 in JVM_MonitorNotifyAll
 #4   0x92886e6c in JVM_SetThreadPriority
 #5   0x92864964 in JVM_Send
 #6   0x9290114c in JNI_CreateJavaVM_Impl
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021428 in _pthread_body

Thread 8:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x0917c668 in 0x917c668
 #7   0x0917a68c in 0x917a68c
 #8   0x0917a68c in 0x917a68c
 #9   0xa2843c38 in _ZTSSt13bad_exception
 #10  0x92838bdc in JVM_CurrentTimeMillis
 #11  0x92878c28 in JVM_FindClassFromClass
 #12  0x92892c90 in JVM_IsSameClassPackage
 #13  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #14  0x928787a0 in JVM_FindClassFromClass
 #15  0x928a51fc in JVM_GetClassMethodsCount
 #16  0x90021428 in _pthread_body

Thread 9:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x0917c668 in 0x917c668
 #7   0x0917a68c in 0x917a68c
 #8   0x0917a5cc in 0x917a5cc
 #9   0x0917a5cc in 0x917a5cc
 #10  0xa2843c38 in _ZTSSt13bad_exception
 #11  0x92838bdc in JVM_CurrentTimeMillis
 #12  0x92878c28 in JVM_FindClassFromClass
 #13  0x92892c90 in JVM_IsSameClassPackage
 #14  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #15  0x928787a0 in JVM_FindClassFromClass
 #16  0x928a51fc in JVM_GetClassMethodsCount
 #17  0x90021428 in _pthread_body

Thread 10:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283de9c in JVM_NewInstance
 #3   0x92844e18 in JVM_GetClassLoader
 #4   0x92844ba4 in JVM_GetClassLoader
 #5   0x928a51fc in JVM_GetClassMethodsCount
 #6   0x90021428 in _pthread_body

Thread 11:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x92903300 in JVM_InitProperties
 #5   0x92903138 in JVM_InitProperties
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021428 in _pthread_body

Thread 12:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x9288890c in JVM_StartThread
 #5   0x92876c10 in JVM_FindLoadedClass
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021428 in _pthread_body

PPC Thread State:
  srr0: 0x929ba640 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x928322b0  ctr: 0x92841c10   mq: 0x00000000
    r0: 0x00000001   r1: 0xf01759e0   r2: 0x928322b0   r3: 0x6c0aee70
    r4: 0x6c0aee70   r5: 0x0011446a   r6: 0x004511a8   r7: 0x6c500000
    r8: 0xa2833a58   r9: 0x00000000  r10: 0x00000008  r11: 0x00000000
   r12: 0x92841c10  r13: 0xa2831c64  r14: 0xa28320ac  r15: 0xa2831fd0
   r16: 0xa28320ac  r17: 0x00000003  r18: 0x00000001  r19: 0xa28320ac
   r20: 0xa284dae8  r21: 0x6c0af000  r22: 0x0003ffc2  r23: 0x00000000
   r24: 0x02670cb0  r25: 0x02670cb0  r26: 0x00000028  r27: 0x6c0aee70
   r28: 0x6c4fffe8  r29: 0x6c0aee70  r30: 0x00000000  r31: 0x928320ac
what build is this from?

java -> beard
Assignee: pinkerton → beard

Comment 2

15 years ago
Barry, for future reference, crash reports should be attached to your bugs as a
text file, and not quoted in a bug comment.

That page contains a Java applet. Barry, are you using Mac OS X 10.2? If so,
probable dup of bug 154699. Reporter, please download a recent trunk nightly
that includes the fix for that bug and retest.

Reassigning to Plug-Ins.
Assignee: beard → bnesse
Component: URL Bar & Autocomplete → Plug-ins
Keywords: crash
QA Contact: sairuh → petersen

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 154699 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.