Closed Bug 1677825 Opened 7 months ago Closed 7 months ago

On Linux, losing WebRender falls back to OpenGL without the GPU process

Categories

(Core :: Graphics: WebRender, defect, P2)

Desktop
Linux
defect

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox83 --- disabled
firefox84 --- fixed
firefox85 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

References

Details

Attachments

(1 file)

If WebRender fails to initialize gracefully, then we will hit this path:

https://searchfox.org/mozilla-central/rev/277ab3925eae21b419167a34624ec0ab518d0c94/gfx/ipc/GPUProcessManager.cpp#477

We disable WebRender via gfxVars, but we didn't disable HW_COMPOSITING like we do if we decide not to give the user WebRender:

https://searchfox.org/mozilla-central/rev/277ab3925eae21b419167a34624ec0ab518d0c94/gfx/config/gfxConfigManager.cpp#344

This means users are falling back to OpenGL if WebRender fails to init.

See Also: → 1654700

If we don't disable hardware acceleration when we lose WebRender, we
will likely fallback to OpenGL compositing. This is not a supported
configuration. We already do this step if we decide against using
WebRender during configuration, but not if it was lost at runtime.

Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/72e7d30ced00
Disable hardware acceleration if WebRender fails to initialize on Linux. r=jrmuizel
See Also: 1654700
Duplicate of this bug: 1654700
Blocks: wr-linux-mvp
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

Comment on attachment 9188404 [details]
Bug 1677825 - Disable hardware acceleration if WebRender fails to initialize on Linux.

Beta/Release Uplift Approval Request

  • User impact if declined: Users may fallback to OpenGL compositing on Linux if errors occur with WebRender. We have never shipped the OpenGL compositor on Linux and it is many bugs.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial change, we just disable hardware compositing (#ifdef'd for Linux only) when we disable WebRender.
  • String changes made/needed:
Attachment #9188404 - Flags: approval-mozilla-beta?

Comment on attachment 9188404 [details]
Bug 1677825 - Disable hardware acceleration if WebRender fails to initialize on Linux.

Approved for 84.0b3.

Attachment #9188404 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Regressions: 1684090
You need to log in before you can comment on or make changes to this bug.