Closed Bug 1678712 Opened 4 years ago Closed 1 month ago

Support multilingual websites in VoiceOver

Categories

(Core :: Disability Access APIs, defect, P3)

All
macOS
defect

Tracking

()

RESOLVED FIXED
129 Branch
Tracking Status
relnote-firefox --- ?
firefox129 --- fixed

People

(Reporter: eeejay, Assigned: eeejay)

References

Details

(Whiteboard: [mac2020_2])

Attachments

(1 file)

I believe this would work with the proper application of AXLanguage

Depends on: 1724032

I have noticed 2 confusing behaviors regarding the use of Voice over with RTL builds:

  1. VoiceOver reads "Arabic letter <some sound>" a bunch of times whenever it attempts to read some string from an Arabic build.
    It also does the same in a Hebrew build.
  2. When pressing VO + left (arrow key), VO focus is moved to the right (and vice-versa). My Morgan's suggestion, this behavior has been reported: bug 1724032.

Tested with Nightly v92.0a1 from 2021-08-04.

No longer depends on: 1724032
Severity: normal → S3
Duplicate of this bug: 1768619

The important part here is to have the text leafs inherit their parents' language.

Assignee: nobody → eitan
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 129 Branch

Release Note Request (optional, but appreciated)
[Why is this notable]: Firefox now supports multiple language content in VoiceOver
[Affects Firefox for Android]: No
[Suggested wording]: Firefox will now support multiple languages in the same document spoken in VoiceOver
[Links (documentation, blog post, etc)]:

relnote-firefox: --- → ?

Added to the Fx129 nightly release notes, please allow 30 minutes for the site to update.
Keeping the relnote-firefox flag as ? to keep it on the radar for inclusion in the final Fx129 release notes

QA Whiteboard: [qa-129b-p2]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: