Closed Bug 1679020 Opened 2 years ago Closed 2 years ago

Portrait mode shows unintended behavior (missing image/ unexpected elements present)

Categories

(Core :: Print Preview, defect, P3)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox84 --- affected
firefox85 --- affected

People

(Reporter: Anca, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [print2020_v85] [old-ui+])

Affected versions

  • 84.0b4
  • 85.0a1 (2020-11-23)

Affected platforms

  • Windows 7
  • Windows 10
  • macOS 10.15
  • Ubuntu 20.04

Steps to reproduce

  1. Open https://www.fruugo.ro/childs-play-5-seed-of-chucky-chucky-11-scale-doll/p-48660354-96577639?language=ro&ac=croud&gclid=CjwKCAiA2O39BRBjEiwApB2Ikj47RPo882tjtweK-FquH9cBmuW9n-QFVo3uxW0i5PYWNTzDddkkDxoCE2QQAvD_BwE
  2. Hit Ctrl + P
  3. Select Portrait orientation and Print backgrounds

Expected result

  • The image is displayed

Actual result

  • The image is missing, a blank space is displayed instead: see screenshot
  • On Windows 7, the image is displayed, but there are four bars, that seems to be loading see screencast; note that these bars are also printed on paper

Regression range

  • Doesn’t seem to be a regression, reproducible way back to Fx 59.0a1

Additional notes

  • Reproducible on old UI
  • The image is missing regardless the Print backgrounds state on Windows 10/ Mac/ Ubuntu, but in order to trigger the behaviour mentioned for Windows 7, background setting is mandatory
  • The image is displayed / bars disappears when in Landscape mode

Suggested severity

  • S3, since other pages could be affected
Has STR: --- → yes

:Anca, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

Component: Printing → Print Preview
Product: Toolkit → Core
Severity: -- → S3
Priority: -- → P3

Actually took a look and this seems like a website issue, the website is making the images transparent before we get to print.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.