Closed Bug 1679023 Opened 2 years ago Closed 1 year ago

Crash in [@ IPCError-browser | ShutDownKill | nsIFrame::ContentSize] when printing worldslongestwebsite.com

Categories

(Core :: Layout, defect)

Firefox 85
Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox85 --- affected

People

(Reporter: emilghitta, Unassigned)

References

Details

(Keywords: crash)

Crash Data

Maybe Fission related. (DOMFissionEnabled=1)

Crash report: https://crash-stats.mozilla.org/report/index/7ba130a1-488c-4d17-afd6-56e950201118

Reason: EXCEPTION_BREAKPOINT

Top 10 frames of crashing thread:

0 xul.dll nsIFrame::ContentSize const layout/generic/nsIFrame.h:1138
1 xul.dll nsBlockFrame::Reflow layout/generic/nsBlockFrame.cpp:1254
2 xul.dll nsBlockFrame::ReflowBlockFrame layout/generic/nsBlockFrame.cpp:3845
3 xul.dll nsBlockFrame::Reflow layout/generic/nsBlockFrame.cpp:1373
4 xul.dll nsBlockFrame::ReflowBlockFrame layout/generic/nsBlockFrame.cpp:3845
5 xul.dll nsBlockFrame::Reflow layout/generic/nsBlockFrame.cpp:1373
6 xul.dll nsBlockFrame::ReflowFloat layout/generic/nsBlockFrame.cpp:6625
7 xul.dll mozilla::BlockReflowInput::FlowAndPlaceFloat layout/generic/BlockReflowInput.cpp:812
8 xul.dll nsBlockFrame::Reflow layout/generic/nsBlockFrame.cpp:1353
9 xul.dll nsContainerFrame::ReflowChild layout/generic/nsContainerFrame.cpp:1082

Encountered this random silent crash while performing the following steps (tried to verify the fix for Bug 1675376) :

  1. Access http://www.worldslongestwebsite.com/
  2. Hit CTRL + P in order to open the print preview.
  3. Click the "Print" button while the print preview is loading.
  4. Click the "Cancel" button.
  5. Stress test the tab by: Clicking the refresh button, the homepage button several times & by typing something inside the Address Bar and hitting enter in order to navigate away from the page.
  6. Close the tab.

After closing the tab, sometimes, a silent crash occurs (Browser notifies that I have an unsubmitted crash)

I'm not sure if this is the right component for this issue. Please feel free to change it.

Thanks for the bug report. This looks more like layout based on the stack, so I'll move it there.

Component: DOM: Navigation → Layout
Summary: Crash in [@ IPCError-browser | ShutDownKill | nsIFrame::ContentSize] → Crash in [@ IPCError-browser | ShutDownKill | nsIFrame::ContentSize] with print preview

I think when we're printing this page we end up creating an infinite amount of pages (or at least with some printfs I've never seen it come to an end).

Depends on: 1675376
Summary: Crash in [@ IPCError-browser | ShutDownKill | nsIFrame::ContentSize] with print preview → Crash in [@ IPCError-browser | ShutDownKill | nsIFrame::ContentSize] when printing worldslongestwebsite.com
Severity: -- → S3

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

There are steps to reproduce the crash, so it shouldn't be closed just because the signature it happened to have went away.

Closing because no crashes reported for 12 weeks.

Status: REOPENED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.