Closed Bug 1679131 Opened 7 months ago Closed 3 months ago

Remove all confirmation modal - icon and close button icons can be dragged

Categories

(Firefox :: about:logins, defect, P3)

Firefox 85
Unspecified
All
defect

Tracking

()

VERIFIED FIXED
86 Branch
Tracking Status
firefox85 --- wontfix
firefox86 --- wontfix
firefox89 --- verified

People

(Reporter: cfogel, Assigned: asahai100, Mentored)

References

Details

(Whiteboard: [lang=css][good first bug])

Attachments

(3 files)

Affected versions

  • 85.0a1(2020-11-24);

Affected platforms

  • macOS 10.15, Windows 10;

Steps to reproduce

  1. Launch Firefox, access about:logins and if no data is saved create at least 1 dummy entry;
  2. Click on the [...] button;
  3. Click on the Remove all button;
  4. Grab elements on the modal and drag them around;

Expected result

  • elements remain in place;

Actual result

  • modal-remove-icon and [x] button icons are draggable (on Win10 only the modal-remove-icon)

Regression range

  • not a regression, visible with addition of [Remove all] feature on added on 2020-11-17/2020-11-18;
  • pushlog URL;
  • bug 1613620;

Additional notes

  • attached recording to illustrate the issue;
  • S4 as suggested severity since the impact is minimal.
Has STR: --- → yes
OS: Unspecified → All
Assignee: nobody → tgiles
Severity: -- → S4
Priority: -- → P3
Status: NEW → ASSIGNED
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0a945d1f6cb0
Prevent warning icon and x icon from being dragged in remove logins dialog. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
Flags: qe-verify+

Testing on the latest Nightly 87.0a1 (2021-01-29) (64-bit) on MacOS revealed a partial fix for this issue:

Hey Tim, should this bug be re-opened or submit a new one for the warning icon?

Flags: needinfo?(tgiles)

Hi Timea, if you could please submit a new bug that is specific for MacOS, that would be great.

Flags: needinfo?(tgiles)

Apologies if I was not clear enough, it is still reproducible on MacOS and Windows as well (did not test linux) so seems like it was not fixed. I will open a new bug for the warning icon if need be, let me know.

Flags: needinfo?(tgiles)

To help Mozilla out with this bug, here's the steps:

  1. Comment here on the bug that you want to volunteer to help.
    This will tell others that you're working on the next steps.
  2. Download and build the Firefox source code
    • If you have any problems, please ask on
      Element/Matrix
      in the #introduction channel. They're there to help you get started.
    • You can also read the
      Developer Guide,
      which has answers to most development questions.
  3. Start working on this bug.
  4. Build your change with mach build and test your change with
    mach test browser/components/aboutlogins/.
    Also check your changes for adherence to our style guidelines by using mach lint
  5. Submit the patch (including an automated test, if applicable) for review.
    Mark me as a reviewer so I'll get an email to come look at your code.
  6. After a series of reviews and changes to your patch,
    I'll mark it for checkin or push it to autoland.
    Your code will soon be shipping to Firefox users worldwide!
  7. ...now you get to think about what kind of bug you'd like to work on next.
    Let me know what you're interested in and I can help you find your next contribution.
Assignee: tgiles → nobody
Mentor: tgiles
Status: RESOLVED → REOPENED
Flags: needinfo?(tgiles)
Resolution: FIXED → ---
Whiteboard: [lang=css][good first bug]

Hi,

Can I take this up? I am new here. And it will be my first contribution. I have set up the build in my windows 10. I think this issue will be good for a newbie like me.
Please let me know, and also it will be great if you can give me a little hint about how to fix this.

Thanks,
Ritanshu Singh

Ritanshu,

Thanks for volunteering! I'll go ahead and assign you the ticket. If you look at Comment #7 under the "Start working on the bug" bullet point, you'll see my recommendation for solving this bug. It should be as straightforward as removing the "user-select" property from the ".warning-icon" class in "remove-logins.dialog.css" file.

Feel free to needinfo me if you have any questions!

Assignee: nobody → ritanshukumarsingh8922

Hi Ritanshu, do you still have time to work on this bug? Are you stuck on the setup/development process? Please let me know if I can help get you unblocked or if you no longer have time to work on this bug. Thanks!

Flags: needinfo?(ritanshukumarsingh8922)
Assignee: ritanshukumarsingh8922 → nobody
Flags: needinfo?(ritanshukumarsingh8922)

Hi.
I'm new here and I'm searching for some good-first issues to work on. This looks like a good start for me. Can I take this up?

Hi Anshul, feel free to submit a patch! I'll assign you the bug, go ahead and review Comment #7 to see how to set up your development environment and what your patch needs to do. Please add me as a reviewer when you submit your patch. If you become stuck or need help, please reach out on Element/Matrix

Assignee: nobody → asahai100

Yes. Thankyou! On it!

Attachment #9210864 - Attachment description: Bug 1679131- removing the "user-select" property r=tgiles → Bug 1679131- Prevent warning icon from being dragged in remove logins dialog r=tgiles
Pushed by tgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b61fa7e72232
Prevent warning icon from being dragged in remove logins dialog r=tgiles
Status: REOPENED → RESOLVED
Closed: 6 months ago3 months ago
Resolution: --- → FIXED

Verified with 89.0a1 (2021-03-25) on Windows 10 and macOS 10.15.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.