Closed Bug 1679156 Opened 2 years ago Closed 2 years ago

“Current page” radio button is enabled on the system dialog for every webpage

Categories

(Core :: Printing: Setup, defect)

All
Windows
defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 --- verified
firefox85 --- verified

People

(Reporter: emilghitta, Assigned: emilio)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [print2020_v84][old-ui+])

Attachments

(2 files)

Attached image CurrentPage.png

Affected versions

  • Firefox 84.0b4 (BuildId:20201122152513)
  • Firefox 85.0a1 (BuildId:20201123095316)

Affected platforms

  • Windows 10 64bit

Unaffected platforms

  • macOS 10.14
  • Ubuntu 20.04 64bit

Steps to reproduce

  1. Launch Firefox.
  2. Access any random webpage.
  3. Hit CTRL + P.
  4. Click on the “Print using the system dialog option”

Expected result

  • The “Current Page” radio button is disabled.

Actual result

  • The “Current Page” radio button is enabled. Selecting the "Current Page" option and clicking print has the same output as the "All" radio button option.

Regression Range

  • This seems to be a regression:
  • Possible regressor: Bug 1675956

Notes

  • For further information please observe the attached screenshot.
  • [Suggested Severity] I think that S3 fits for this issue.

Hi Emilio!

Can you please take a look?

Thank you!

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Flags: needinfo?(emilio)

This was accidentally enabled when moving to the more modern print dialog API.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cb700708fe36
Disable "Current Page" checkbox in the Windows print dialog. r=bobowen
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

The patch landed in nightly and beta is affected.
:emilio, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

Comment on attachment 9189649 [details]
Bug 1679156 - Disable "Current Page" checkbox in the Windows print dialog. r=jfkthame,bobowen

Beta/Release Uplift Approval Request

  • User impact if declined: current page option appears and is ignored in the windows print dialog.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple flag to disable the checkbox and fix the regression.
  • String changes made/needed: none
Flags: needinfo?(emilio)
Attachment #9189649 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9189649 [details]
Bug 1679156 - Disable "Current Page" checkbox in the Windows print dialog. r=jfkthame,bobowen

Approved for 84.0b7.

Attachment #9189649 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
Has Regression Range: --- → yes
Has STR: --- → yes

Hello,

Reproduced this issue with a mozregression build from 2020-11-24.

Confirming this issue as verified fixed on 84.0b7(20201201213706)and 85.0a1(20201202091636) and on Win10x64, Win10x64aarch, Win7x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.