command line option -P"foo" without a space before "foo" is not handled

RESOLVED INVALID

Status

Core Graveyard
Cmd-line Features
RESOLVED INVALID
16 years ago
9 years ago

People

(Reporter: dantish, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

Category is command line parser

Command line option -P provides a way to specify the user profile name so that
the browser can start without the dialog box to select which user profile.  This
worked in Netscape v4.79, but not Mozilla v1.1 using:

D:\Netscape\Program\netscape.exe -P"opty" 
D:\Mozilla\mozilla.exe -P"opty" 

Netscape starts with the 'opty' profile without a dialog box.  
Mozilla ignores the command line spec and starts with a dialog box.


Reproducible: Always

Steps to Reproduce:
1. If there is only one profile, create another with profile manager.
2. Create a new desktop link to Mozilla.exe and note that there is a dialog to
select the profile when Mozilla starts.
3. In the new link to Mozilla, edit the command line to include -P"profname",
where "profname' is one of the Mozilla profile names.


Actual Results:  
The dialog still happens when Mozilla starts.

Expected Results:  
Start without the dialog.

Maybe part of the problem:  Does the command line parser care about the order 
of multiple command line specs such as 
D:\Mozilla\mozilla.exe -P"profname" -composer index.htm

My intended use was to have several desktop links with URL on the command line
too.  This would allow each desktop link to launch the browser to a specified
site with cookies and security set appropriately for the site.  Netscape seemed
to accept no more than one command line arg, do it didn't do it either.
You need a space after the "-P".... So:

D:\Mozilla\mozilla.exe -P "opty" 
Comments from reporter:

Yup, that fixes it.  Thanks.
I was following the Netscape syntax:
http://developer.netscape.com/docs/manuals/deploymt/options.htm


Over to command-line stuff to see whether we want to support the old syntax.
Assignee: asa → law
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: Cmd-line Features
Ever confirmed: true
QA Contact: asa → sairuh

Comment 3

14 years ago
Have Mozilla 1.4 fr running on mswin-98SE-fr:
This option worked in Moz 1.3.1 -- now works only if the profile name has no
international characters. (e.g.: é = é)
Without the accent in works exactly as documented on-line.
(i.e.: upper OR lower case -P, quotes optional if no space in profile name.)
Unfortunately my name is André ...

Comment 4

14 years ago
no, that's a totally unrelated bug, please file a new bug against jshin@mail

Updated

14 years ago
Summary: command line option -P does nothing → command line option -P"foo" without a space before "foo" is not handled

Updated

11 years ago
Assignee: law → nobody
QA Contact: bugzilla

Comment 5

11 years ago
not a bug
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.